iHyperDB版本发布说明

Navigation: »No topics above this level«

iHyperDB版本发布说明

 Return to chapter overview

本手册介绍iHyperDB各版本发布说明。

--

对产品或产品文档有任何修改建议或意见，请通过下列平台用户反馈渠道进行联系。

1）实时数据库平台支持：李琳 lilin@baosight.com

2）应用交流QQ群 236310467

3）应用平台机会以及需求提交到产品经理 代真虎 daizhenhu@baosight.com

4）产品支持网站: iHyperDB支持


2.0.0

2.0.0

1新增功能特性

1.1历史记录统计

可统计一个Tag指定时间段内的有效记录数，统计数据平均值、最大值、最小值、积分等等，支持按月统计，包括自然月和生产月。具体请参考使用帮助手册“数据源配置 > 新建Tag点”相关说明。

1.2增加统计记录的转储

数据转储到关系数据库功能中增加统计记录的转储。

1.3变量分组管理

提供对Tag树状层级的分组管理功能，可以按照MES制造工厂模型结构，管理生产过程数据Tag。iHyperDB的资源管理器是对ihyperDB服务器上的Tag点进行分组管理的系统，通过这个工具，用户可以方便的对Tag点进行分组，方便用户管理。可对分组进行添加、删除、移动、重命名等操作。具体参考使用帮助手册中的“系统管理 > 资源管理器”内容。

1.4模块化

内部实现模块化方案基础包，安装程序集成模块化管理工具。

2已解决的用户反馈

编号 | 类型 | 描述
0002104 | Requirement | 实时数据库支持MySQL
0002128 | Requirement | Tag点的分组管理
0002360 | Fault | 实时数据库opc采集器 不能采集某些opcserver数据

以上用户反馈来自网站：http://product.baosight.com/feedback/login_page.php

可访问该网站提交并跟踪用户反馈。

3已修复的缺陷

* 解决64位操作系统不能安装的问题。
* 修复安装程序环境变量放在最后一个，有可能导致环境变量识别错误导致不能服务运行的问题，将安装程序环境变量调整到前面。
* 修复报警记录产生时，优先级颜色提示有时不正确的问题。
* 修复诊断工具停止服务后，不点刷新按钮界面上服务状态不变的问题。
* 解决实时数据库opc采集器不能采集iFix OPC Server数据的问题。
* 解决使用接口sn_save_snapshots时，第一次加5W点记录速度很慢的问题。
* 解决历史报警记录第一条结束时间为1970年，再产生一条报警后才能正确显示的问题。

4已知问题与限制

ID | 描述 | 缺陷等级 | 规避措施
222413 | 冗余：有冗余机下线时，需要重连才能正常操作 | 4 | 后续改进。暂时重新连接。
223635 | 冗余：配置了冗余之后，且服务器名为中文，无法修改管理权限 | 4 | 后续改进，服务器名需要修改为英文。
222926 | 宽表转储：小数点位数被截断 | 4 | 后续支持脚本转储，用户通过自定义实现
223737 | 记录：浮点型（float32，float64）上传超范围值，框架中显示为inf，excel中显示的数值也不正确。建议超范围值截断或不能上传。 | 4 | 极限情况，一般工控数据不会超过float64的量程。此种情况一般是传感器故障，应该检查硬件。
223791 | excel中tag下载-tag查询-高级查询，用记录取值范围进行等于查询，记录取值范围=2147483904，查询为空 | 4 | 取值范围溢出，后续考虑在前台加校验进行规避
223795 | 在历史存储记录界面（时间区间模式），按ctrl+/进入修改状态，修改数组函数的Tag名（从有2条记录的Tag1改为只有1条记录的Tag2），并完成修改，显示两条一样的记录，不是有一条显示N/A | 4 | 不影响使用。如果有一样的记录，后续记录忽略。
225236 | 在Excel中，设置判断条件为LT(-1.1E-10)，且对应源Tag为数值型(浮点型：float32,float64)，设置值为-0.00000000012，没有进行报警 | 4 | 被截断，后续版本改进
232856 | 性能：加500w点，点加不进去 | 2 | 内存不足，百万级以上的点需要使用64位版本
236258 | 转储：SQLserver和mysql，普通点关系—>实时，转储异常，普通点关系—>实时，转储异常 | 3 | 原因：1. 未正确初始化TagType，配置数值类型（int,float等）判断为string类型，delete buffer引起异常 2. 导入及导出服务未检查进程是否唯一，同时有多个导入或导出进程运行，退出时异常。 3. 补丁中已修复

5升级说明

5.1升级范围

组件（或节点） | 必须升级 | 推荐升级 | 不需要升级 | 其他影响
内核/服务端 | ? |  |  | 1.2.0版本根据下面升级说明备份原有配置和数据，然后升级，1.2.0以前版本请联系应用支持人员
客户端 | ? |  |  |
采集器端 | ? |  |  |

5.2升级方法

* 版本升级支持从1.2.0版本升级到最新2.0.0版本，配置和数据通过脚本升级。

1.备份1.2.0版本的配置和数据到一个文件夹，如O:\bak_iHyperDB；

2.安装新版本，运行新版本安装路径的doc目录下的findupdate.bat；

3.修改升级脚本（新版本安装路径的dist文件夹内update12data.bat），设置新路径为实际路径，set OLD_BAK=O:\bak_iHyperDB；

4.运行升级bat脚本，注意是否错误提示，如提示路径设置不对，请返回第3）步重新设置；

5.检查配置、验证原有系统功能。


2.0.0_P1

Navigation: 2.0.0 >

2.0.0_P1

 Return to chapter overview

1新增的功能特性

1.1新增计算点功能

Ø[234130,181177]新增计算点功能，对原始数据计算与存储，支持基本逻辑、关系和四则运算

系统管理 > 数据源配置 > 新建Tag点， 计算页面

目前计算点可以算相关点的所有历史数据，下一个版本加计算的起始时间。

1.2新增通过excel方式的创建修改分组及Tag点

Ø[235624]支持通过excel创建分组以及与Tag点的关联关系的excel导入导出

数据展示 > 电子表格 > Excel中iHyperDB插件的功能 > Tag分组上传和下载

注：1）TagID以及Tag名称整个数据库不能重名

2）节点ID在创建点时不需要配置

1.3支持转储到Oracle数据库

Ø[236901]支持转储到Oracle数据库，请参考用户手册：

数据存储 > 数据转储

1.4新增Python脚本自定义规则转储

Ø[231085]数据转储到关系数据库支持Python脚本自定义规则转储

Python使用2.7版本，点击“添加”有示例脚本供参考。

1.5OPC采集器支持采集冗余iCV服务器数据

需求编号[235397]，具体参考用户手册：

数据采集 > OPC采集器 > OPC采集端支持ICV服务器冗余

1.6系统管理工具支持错误码查询

需求编号[236066]

1.7增加试用2小时机制，限制5000点

[238383]安装成功后，无需许可证文件可试用运行2小时，限制5000点，用于临时使用。

2增强或变化的功能特性

Ø[233603]支持digital数据类型压缩（默认开启压缩），DI量硬盘存储空间占用减少

Ø[236203]资源管理分组服务支持报警点挂载

Ø[236203]API支持批量报警记录查询

易用性改进

Ø[237634]补丁安装失败弹出界面提示

Ø[236066]Tag分组配置的资源管理界面，翻页选择的交互进行优化

Ø[236066]系统管理工具选择连接服务器优化，选点界面分别记忆最近选择的服务器

Ø[235365]OPC采集器可安装为windows服务，随操作系统自动启动

Ø[235578]内核或网络再重启后，报警服务能自动连上内核

3已解决的用户反馈

Ø[0002458]采集器配置工具未对包含非法字符的字符串做校验和处理

Ø[0002623]当归档文件大小设置较大，比如6G时，容易导致hdKernel CPU100%

Ø[0002134]提供计算点功能

Ø[0002367]实时数据库要支持digital数据类型压缩

Ø[0002356]opc采集器冗余

Ø[0002129]转储到关系数据库功能扩展，可以执行用户自定义规则

以上用户反馈来自网站：http://product.baosight.com/feedback/login_page.php

可访问该网站提交并跟踪用户反馈。

4已修复的缺陷

Ø通过API给不存在配置的Tag ID的点加数据导致Kernel异常退出

ØVC10，VC6调用hdAPI动态加载DLL无法退出

Ø[238949]不支持单个归档文件大于4G，理论上可支持2的64次方，建议配置100G以内。

Ø[239911]报警点数量大于37万后导致服务异常

Ø[239813]转储配置新增关系数据库后马上删除，该数据库配置项无法成功删除

Ø[237587]采集器配置工具对非法字符拷贝添加为设备名称没有校验

Ø[237138]采集器不支持中文名

5已知问题与限制

ID | 描述 | 等级 | 规避措施
222413 | 冗余：有冗余机下线时，需要重连才能正常操作 | 4 | 后续改进。暂时重新连接。
223635 | 冗余：配置了冗余之后，且服务器名为中文，无法修改管理权限 | 4 | 后续改进，服务器名需要修改为英文。
222926 | 宽表转储：小数点位数被截断 | 4 | 支持脚本转储，用户通过自定义实现
223737 | 记录：浮点型（float32，float64）上传超范围值，框架中显示为inf，excel中显示的数值也不正确。建议超范围值截断或不能上传。 | 4 | 极限情况，一般工控数据不会超过float64的量程。此种情况一般是传感器故障，应该检查硬件。
223791 | excel中tag下载-tag查询-高级查询，用记录取值范围进行等于查询，记录取值范围=2147483904，查询为空 | 4 | 取值范围溢出，后续考虑在前台加校验进行规避
223795 | 在历史存储记录界面（时间区间模式），按ctrl+/进入修改状态，修改数组函数的Tag名（从有2条记录的Tag1改为只有1条记录的Tag2），并完成修改，显示两条一样的记录，不是有一条显示N/A | 4 | 不影响使用。如果有一样的记录，后续记录忽略。
225236 | 在Excel中，设置判断条件为LT(-1.1E-10)，且对应源Tag为数值型(浮点型：float32,float64)，设置值为-0.00000000012，没有进行报警 | 4 | 被截断，后续版本改进
232856 | 性能：加500w点，点加不进去 | 2 | 内存不足，百万级以上的点需要使用64位版本

6升级说明

6.1 升级范围

组件（或节点） | 必须升级 | 推荐升级 | 不需要升级 | 其他影响
内核/服务端 | ? |  |  |
客户端 | ? |  |  |
采集器端 | ? |  |  |
资源管理服务（Tag变量分组） | ? |  |  |

6.2 升级方法

1.从2.0.0_BUILD_0712版本升级到2.0P1

直接运行2.0.0_P1_20121012版本的iHyperDBSetup.exe文件，覆盖安装。安装过程后面提示安装Python2.7，请注意需要安装，否则转储自定义脚本运行会失败。

1.从1.2.0版本升级到2.0P1

1.2.0版本可以直接升级到2.0P1，不用安装中间版本。根据下面升级说明备份原有配置和数据，然后升级，服务端配置和数据需通过脚本升级。

1.备份1.2.0版本的配置和数据到一个文件夹，如O:\bak_iHyperDB；

2.安装新版本，运行新版本安装路径的doc目录下的findupdate.bat准备升级脚本；

3.修改升级脚本（新版本安装路径的dist文件夹内update12data.bat），设置路径为实际路径，如set OLD_BAK=O:\bak_iHyperDB；

4.运行升级脚本update12data.bat，注意是否错误提示，如提示路径设置不对，请返回第3）步重新设置；

5.检查配置、验证原有系统功能。

注意：采集器端运行前需使用采集器配置工具重新本地应用。

2.1.2.0以前版本请联系应用支持人员协助升级。


2.1.0

2.1.0

1新增的功能特性

1.1数据备份和恢复

[238539]数据的备份/恢复（带配置和状态监控界面）

备份系统有手动备份和自动备份两种模式可供选择。用户可自定义备份和恢复的各项参数，启动停止备份或者恢复动作，实时监控本机的备份任务执行情况。

数据安全 > 数据备份

1.2一台数采机上的opc采集器能采集不同的opcserver的数据

[240248]增加报警值死区和时间死区的功能

1.3一台数采机上的opc采集器能采集不同的opcserver的数据

Ø[238889]一台数采机上的opc采集器能采集不同的opcserver的数据

1.4 支持iCV组态和趋势图进行数据展示

[235628]支持iCV组态和趋势图进行数据展示

1.5支持硬件狗许可证

[241394] 支持硬件狗许可证

使用硬件许可证可以不限制绑定mac地址。

1.6 变量分组支持计算点

Ø[231317]变量分组支持计算点

2增强或变化的功能特性

Ø用户手册userhelp.chm独立在setup.exe外，安装时需与exe放在同一目录下。

Ø无许可证时，2小时临时试用版本可以使用3w点。

Ø[241523] (),[],+,=,%,@.- 这些特殊字符需要在tag点名中能支持

ØAPI网络连接方式需成对调用connect和disconnect

Ø二次开发 > API接口 > 连接管理接口 > nt_connect

Ø连接成功后得到服务器句柄，调用nt_disconnect来断开与服务器的连接；nt_connect和nt_disconnect采用引用计算，需要确保成对使用。

Ø

Ø [240261] 新插值模式接口可以获取插值点前一个原始值

Ø二次开发 > API接口 > 归档数据接口 > ar_query_interp_records_by_mode

Ø插值类型， 1表示前向插值，即将某一个时刻之前最近的一条原始值作为改时刻的插值；值为0表示线性插值，即根据某一时刻之前的最近一条原始值和该时刻之后最近一条原始值来进行线性计算该时刻的插值。

Ø已解决的用户反馈

Ø[0002131] 提供数据备份与恢复的功能

Ø以上用户反馈来自网站：http://product.baosight.com/feedback/login_page.php

Ø可访问该网站提交并跟踪用户反馈。

3已修复的缺陷

Ø[243707]关系数据库采集器：若未配置规则中的Tag点的数据值采集，则忽略该点的数据质量采集；不同点的采集互不影响。

Ø[244514]关系数据库采集异常后无法采集或采集数据记录不全。

Ø[244160]统计服务有时初始化不成功导致一直不能统计历史记录。

4已知问题与限制

ID | 描述 | 等级 | 规避措施
244636 | 转储：中文表字段名无法配置 | 4 | 字段名需使用英文
244601 | 分组：服务器ip为127.0.0.1的问题 | 4 | 需使用服务器实际ip
245096 | 转储：自定义转储，转储报警点时，最后一个字段为注释时间，会有null出现 | 4 | 报警注释避免使用特殊字符：引号’
222413 | 冗余：有冗余机下线时，需要重连才能正常操作 | 4 | 后续改进。暂时重新连接。
244462 | 备份：备份服务有时进程间通信权限问题 | 4 | 需重启备份服务。
223635 | 冗余：配置了冗余之后，且服务器名为中文，无法修改管理权限 | 4 | 后续改进，服务器名需要修改为英文。
222926 | 宽表转储：小数点位数被截断 | 4 | 支持脚本转储，用户通过自定义实现
223737 | 记录：浮点型（float32，float64）上传超范围值，框架中显示为inf，excel中显示的数值也不正确。建议超范围值截断或不能上传。 | 4 | 极限情况，一般工控数据不会超过float64的量程。此种情况一般是传感器故障，应该检查硬件。
223791 | excel中tag下载-tag查询-高级查询，用记录取值范围进行等于查询，记录取值范围=2147483904，查询为空 | 4 | 取值范围溢出，后续考虑在前台加校验进行规避
223795 | 在历史存储记录界面（时间区间模式），按ctrl+/进入修改状态，修改数组函数的Tag名（从有2条记录的Tag1改为只有1条记录的Tag2），并完成修改，显示两条一样的记录，不是有一条显示N/A | 4 | 不影响使用。如果有一样的记录，后续记录忽略。
225236 | 在Excel中，设置判断条件为LT(-1.1E-10)，且对应源Tag为数值型(浮点型：float32,float64)，设置值为-0.00000000012，没有进行报警 | 4 | 被截断，后续版本改进
245081 | 转储：自定义转储界面，描述超长1024,点击保存，界面自动退出 | 3 | 重启客户端，配置正常描述长度
245074 | 许可证升级工具：升级成功或者失败后弹出的提示框中标题不完整，建议修改 | 4 | 提示框不必关注
245077 | OEM：定制信息中缺少helpdoc项，安装时运行参数中的各项均为空，无默认值，建议给出默认值。 | 4 | 不影响使用，手工填写运行参数配置就可以安装。请代理商确认setup.ini配置正确
245072 | SysInfo: 放一晚上发现内存有上涨趋势 | 4 | 不推荐使用SysInfo采集器
244644 | 备份：恢复时弹出“有任务正在执行”框，实际没有。 | 4 | 有任务在执行，原因是执行备份任务的线程退出，未更新当前执行任务状态
245090 | 备份：许可证过期后，建议备份列表界面给出相应的提示。 | 4 | 备份是部署在独立客户端，不检测许可证状态
244601 | 分组：服务器ip为127.0.0.1的问题 | 4 | 需使用服务器实际ip
245096 | 转储：自定义转储，转储报警点时，最后一个字段为注释时间，会有null出现 | 4 | 报警注释避免使用特殊字符：引号’
244636 | 转储：中文表字段名无法配置 | 4 | 字段名需使用英文

5升级说明

5.1 升级范围

组件（或节点） | 必须升级 | 推荐升级 | 不需要升级 | 其他影响
内核/服务端 | ? |  |  |
客户端 | ? |  |  |
采集器端 | ? |  |  |
资源管理服务（Tag变量分组） | ? |  |  |

5.2 升级方法

从2.0.0版本升级到2.1.0

直接运行iHyperDBSetup.exe文件，覆盖安装。


2.1.1

2.1.1

1增强或变化的功能特性

Ø历史记录查询的时间输入框由2000年改为当前时间。

ØWin7等操作系统有UAC权限控制时运行iHyperDB程序可以给提示申请权限。

2已修复的缺陷

Ø[245414] 安装：通过安装程序生成的servercfg.xml配置不正确。

Ø[245072] SysInfo: 放一晚上发现内存有上涨趋势。

Ø[244644] 备份：恢复时弹出“有任务正在执行”框，实际没有。

Ø[244636] 转储：中文表字段名无法使用却没有限制配置。

Ø[245081] 转储：自定义转储界面，描述超长1024,点击保存，界面自动退出

3已知问题与限制

ID | 描述 | 等级 | 规避措施
245472 | 采集器配置：配置扫描组多于20个，后面的扫描组的周期、相位、扫描类型无法显示 | 4 | 重启配置后可以显示
244601 | 分组：服务器ip为127.0.0.1的问题 | 4 | 需使用服务器实际ip
245096 | 转储：自定义转储，转储报警点时，最后一个字段为注释时间，会有null出现 | 4 | 报警注释避免使用特殊字符：引号’
222413 | 冗余：有冗余机下线时，需要重连才能正常操作 | 4 | 后续改进。暂时重新连接。
244462 | 备份：备份服务有时进程间通信权限问题 | 4 | 需重启备份服务。
223635 | 冗余：配置了冗余之后，且服务器名为中文，无法修改管理权限 | 4 | 后续改进，服务器名需要修改为英文。
222926 | 宽表转储：小数点位数被截断 | 4 | 支持脚本转储，用户通过自定义实现
223737 | 记录：浮点型（float32，float64）上传超范围值，框架中显示为inf，excel中显示的数值也不正确。建议超范围值截断或不能上传。 | 4 | 极限情况，一般工控数据不会超过float64的量程。此种情况一般是传感器故障，应该检查硬件。
223791 | excel中tag下载-tag查询-高级查询，用记录取值范围进行等于查询，记录取值范围=2147483904，查询为空 | 4 | 取值范围溢出，后续考虑在前台加校验进行规避
223795 | 在历史存储记录界面（时间区间模式），按ctrl+/进入修改状态，修改数组函数的Tag名（从有2条记录的Tag1改为只有1条记录的Tag2），并完成修改，显示两条一样的记录，不是有一条显示N/A | 4 | 不影响使用。如果有一样的记录，后续记录忽略。
225236 | 在Excel中，设置判断条件为LT(-1.1E-10)，且对应源Tag为数值型(浮点型：float32,float64)，设置值为-0.00000000012，没有进行报警 | 4 | 被截断，后续版本改进
245081 | 转储：自定义转储界面，描述超长1024,点击保存，界面自动退出 | 3 | 重启客户端，配置正常描述长度
245074 | 许可证升级工具：升级成功或者失败后弹出的提示框中标题不完整，建议修改 | 4 | 提示框不必关注
245077 | OEM：定制信息中缺少helpdoc项，安装时运行参数中的各项均为空，无默认值，建议给出默认值。 | 4 | 不影响使用，手工填写运行参数配置就可以安装。请代理商确认setup.ini配置正确
245072 | SysInfo: 放一晚上发现内存有上涨趋势 | 4 | 不推荐使用SysInfo采集器
244644 | 备份：恢复时弹出“有任务正在执行”框，实际没有。 | 4 | 有任务在执行，原因是执行备份任务的线程退出，未更新当前执行任务状态
245090 | 备份：许可证过期后，建议备份列表界面给出相应的提示。 | 4 | 备份是部署在独立客户端，不检测许可证状态
244601 | 分组：服务器ip为127.0.0.1的问题 | 4 | 需使用服务器实际ip
245096 | 转储：自定义转储，转储报警点时，最后一个字段为注释时间，会有null出现 | 4 | 报警注释避免使用特殊字符：引号’
244636 | 转储：中文表字段名无法配置 | 4 | 字段名需使用英文

4升级说明

4.1 升级范围

组件（或节点） | 必须升级 | 推荐升级 | 不需要升级 | 其他影响
内核/服务端 | ? |  |  |
客户端 | ? |  |  |
采集器端 | ? |  |  |
资源管理服务（Tag变量分组） | ? |  |  |

4.2 升级方法

1?从2.0.0以及更高版本升级

直接运行iHyperDBSetup.exe文件，覆盖安装。


2.2.0

2.2.0

1新增功能特性

Ø增加批量添加普通点接口pt_add_tags，每次调用最多添加100个tag点，具体参见API说明，普通服务器500点/秒以上。Excel插件添加普通点使用批量加点接口。

Ø增加Excel插件函数：

ohd_GetAverageValRange：获取某一时间段历史记录平均值。

ohd_GetSumValRange：获取某一时间段历史记录累积值。

ohd_GetVal：获取某一时间点历史记录

ØOPC采集器支持同步轮询的相位设置

ØOPC采集器支持命令行参数-name指定运行的采集器名称

Ø[245093]报警点可以配置计算点和统计点为源点

Ø[245773]增加CS组态运行客户端和SPC配置客户端

Ø[246028]Excel插件查询时间支持yyyy/mm/dd和yyyy-mm-dd格式

Ø[244530]Excel插件查询工具：能同时查询多个tag点的插值历史数据

Ø[244535]计算点需要能计算历史数据

Ø[235715]历史报警记录可以导出csv

2增强或变化的功能特性

Ø缓存文件切换操作性能提升，解决大数据量时查询数据和存储数据经常超时

Ø[244112]采集端配置工具界面优化调整

Ø[238022]界面：系统管理工具界面优化调整

Ø[245766]OPC采集器改进,连接不上服务端不要自行停止

Ø[244128]数据转储功能改进

Ø[244175]关系数据库转储配置改进

ØExcel上传如果有部分失败可继续操作，最后提供操作失败信息。

Ø[245764]系统管理工具：查询点无记录时，建议有提示，而不是没有反应

Ø[245549]统计点功能改进：支持从本月的31日到下月的31日

Ø[244600]Tag分组管理进程可被安装成服务 hdResMgrSrv

Ø分组管理服务IP可修改

Ø[245465]许可证工具：当许可证过期时连接可有提示

Ø[245523]备份工具界面：备份库名检验空格

Ø[245519]备份工具界面：校验月日都要填

Ø[245521]备份工具界面：端口号为空时，测试连接建议提示端口号不合法

Ø[243579]安装为Windows系统服务增加依赖关系

3已修复的缺陷

Ø[244601]分组：服务器ip为127.0.0.1不能远程访问

Ø[246720]计算：配置大批量计算点后，大部分计算点无法计算

Ø内核：digital、string、blog插值返回时间戳不是插值时间

Ø[246899]网络：禁用网卡、未获得IP时，建议使用127.0.0.1也能成功连接

Ø[246666]安装：config下多了LogClient2

Ø[246173]关系数据库转储：修改服务器ip有时hdRDBExporter异常退出

Ø[244462]备份：有时进程间通信权限问题，重启客户端后恢复

Ø[246029]备份界面：出现"备份监控页面初始化失败"提示

Ø[245826]excel插件：数组公式编辑和使用时会导致excel退出时崩溃

Ø[245900]修复计算点批量添加有时锁竞争导致计算的结果错乱

Ø[245472]采集器配置：配置扫描组多于20个，后面的扫描组的周期、相位、扫描类型无法显示

Ø[245470]修复tag分组查询缺陷：tag点为-:._()[]+=%@#，分组中查询不出

Ø[245965]tag分组：节点名会自己变化

Ø[245974]报警组配置有时框架中加载失败

Ø[245102]用户手册缺少新加的许可证和硬件狗的内容

Ø[249242]用户手册:excel插件模块缺少内容

Ø[249237]普通点：删除与报警点关联的普通点

Ø[249238]普通点：删除与计算点关联的普通点

Ø[249451]采集器: buffer+opc， iHD服务器断网重连后，有数据丢失

Ø[249770]备份：开始菜单中备份工具名称过长

Ø[249468]buffer: 建议缓存路径只能配置绝对路径

4解决的用户反馈

Ø[0002855]安装程序没有添加安装路径下的executable到PATH环境变量，会导致excel插件启动报错

Ø[0002869]计算点配置后，实际计算的结果错乱

Ø[0002847]采集器配置：配置扫描组多于20个，后面的扫描组的周期、相位、扫描类型无法显示

Ø[0002860]采集器不能添加同名的opcserver

Ø[0002857]统计点功能无法配置上月末至本月末的时间统计

Ø[0002856]excel上传或删除，碰到不能完成的行，应该继续走下去

5已知问题与限制

ID | 描述 | 等级 | 规避措施
250222 | 转储：报警点转储多次添加表映射有重复记录 | 3 | 同样规则转储避免多次添加
249826 | 采集器：变更tag属性，重连周期未到，采集不到数据 | 4 | 有时采集器配置不能自动更新，需重启采集器进程或服务
250146 | Excel插值：函数参数，TagName框中输入Tag名后，Tag名未自动加双引号。 | 4 | 某些字符串不会自动加""，是excel自动做的，插件无法修改.一般使用单元格选择tag名不会遇到这个问题.
249568 | 报警查看注释问题 | 4 | 报警注释添加成功的提示不正确
249512 | 组态有时运行态不能F7退出 | 4 | 检查ZtDesign或Ztrun是否未正常退出，手工杀掉进程。
222413 | 冗余：有冗余机下线时，需要重连才能正常操作 | 4 | 后续改进。暂时重新连接。
223635 | 冗余：配置了冗余之后，且服务器名为中文，无法修改管理权限 | 4 | 后续改进，服务器名需要修改为英文。
222926 | 宽表转储：小数点位数被截断 | 4 | 支持脚本转储，用户通过自定义实现
223737 | 记录：浮点型（float32，float64）上传超范围值，框架中显示为inf，excel中显示的数值也不正确。建议超范围值截断或不能上传。 | 4 | 极限情况，一般工控数据不会超过float64的量程。此种情况一般是传感器故障，应该检查硬件。
223791 | excel中tag下载-tag查询-高级查询，用记录取值范围进行等于查询，记录取值范围=2147483904，查询为空 | 4 | 取值范围溢出，后续考虑在前台加校验进行规避
223795 | 在历史存储记录界面（时间区间模式），按ctrl+/进入修改状态，修改数组函数的Tag名（从有2条记录的Tag1改为只有1条记录的Tag2），并完成修改，显示两条一样的记录，不是有一条显示N/A | 4 | 不影响使用。如果有一样的记录，后续记录忽略。
225236 | 在Excel中，设置判断条件为LT(-1.1E-10)，且对应源Tag为数值型(浮点型：float32,float64)，设置值为-0.00000000012，没有进行报警 | 4 | 被截断，后续版本改进

6升级说明

6.1 升级范围

组件（或节点） | 必须升级 | 推荐升级 | 不需要升级 | 其他影响
内核/服务端 | ? |  |  |
客户端 | ? |  |  |
采集器端 | ? |  |  | 2.2.0之前配置的采集器，如果升级的话，由于升级前的opcint服务会自动启动，如果需要使用新的采集器配置方式，需要手工删除老的opcint服务，重新配置保存。
资源管理服务（Tag变量分组） | ? |  |  |

6.2 升级方法

1?从2.0.0以及更高版本升级

直接运行iHyperDBSetup.exe文件，覆盖安装。


2.2.5

2.2.5

1新增功能特性

Ø组态系统独立部署

CS部署过程：

1.客户端安装组态客户端；

2.服务端安装分发配置服务组件；

3.在有权限的用户可以通过客户端系统管理工具中的分发配置进行组态相关的配置，包括组态要运行的HMI节点配置，组态画面配置，组态函数库脚本，图库，WEB节点升级包（用于IE访问的控件自动升级）等。

4.将第3步做好的组态文件等分发到准备运行组态的HMI客户端上；

5.在HMI客户端上点击组态运行客户端快速链接进入组态运行态，按钮F6/F7可以进行组态运行态和编辑态的切换。注意在编辑态时编辑的是本地文件，必须通过HMI的系统管理工具中的分发配置的迁出、迁入（或导入）操作，才能提交到服务器上。

Ø组态数据回放

增加组态控件，通过该控件可以切换历史数据回放和实时数据显示2种模式，切换操作对当前画面运行的客户端有效。

该控件包含在组态客户端中，在使用时可以通过组态设计器的绘图->activex控件中的hdztPlay控件，拖拽到页面上，设定合适的大小，双击控件中的 [image] 图标，可以设定控件的属性，包括背景色。

ØWeb发布包分发（用于IE访问的控件自动升级）

ØSDK安装包，支持C++/Java/C#二次开发。iHDSDKSetup.exe

ØSPC报警

可以进行SPC分析的实时报警，当前版本实现的控制图是xbar（平均值），关联的TAG源点是统计点（平均值）。举例说明，比如1分钟的瓦斯浓度平均值，连续6分钟（6个点）递增（判异准则3），此时尽管瓦斯浓度还没有达到报警边界值，但SPC的实时报警可以根据判异准则3（连续上升的趋势）提前预判报警，从而提前发现瓦斯泄露，给现场充足的处理时间。

Ø服务端管理工具，提供界面启停进程和服务、展示许可证信息、修改服务器参数（能扩充归档历史数据文件系统参数）、监视服务器端状态（CPU使用情况，内存占用情况，硬盘剩余空间，网络流量）

其中归档文件个数，原来的版本在安装后不能调整，当前版本可以修改，以便用户根据硬盘空间增加归档文件个数，目前该参数最大为500.如果系统数据量较大，建议在安装时，可以将归档文件的大小设置大一些，比如4G，则最大归档空间可为2T。

Ø增加采集器状态查询：是否连接，正在采集的活动点数

Ø统计点新增统计类型：指定时间段计算差值、计数统计区间是否包含指定值

Ø计算点支持多级条件判断的表达式 if then else if else

Ø转储到关系数据库：新增支持DB2

Ø关系库采集数据：支持MySQL/Oracle/SQLServer/DB2

Ø数字量状态集改进：支持负数

Ø

Ø

2增强或变化的功能特性

Ø支持iHD的组态客户端和iCV的客户端安装在同一台机器上,分发客户端代理hdDagent默认端口5676

ØOPC采集器数据质量增加设备断开时设置超时，可以在采集器状态查询界面展示采集器状态

ØOPC采集器在网络服务断开时添加停机记录修改去掉，停机记录表示采集器停止工作

Ø计算点：处理一些异常情况时的计算点应该遵循的规则,表达式中某一参与计算的原始点质量为非GOOD，执行计算，计算结果质量为BAD

Ø实时数据库对连接但无数据交互的客户端作超时限制

Ø历史记录查询界面显示浮点数据精度提高到小数后6位

ØExcel批量上传点时错误信息的提示改进，有出错的点不影响其他点的上传，在上传完成后，出错的点用红色标识，最后有一列提示错误信息，如下图

Øtag分组配置

可显示tag变量对应服务器信息，如果IHD的IP地址变化，或者WEB访问需要使用其他IP地址时，可以直接在此页面进行修改IP地址，而不需要重新根据新的IHD的IP地址进行分组和点的关联。

提供分组客户端配置界面，主要是适用的场景：不同的分组配置客户端，可以配置不同的IHD server上的分组，因此界面中的服务端的IP地址和端口，是指分组服务装在哪一个IHD 的server上，对应的分组服务端口是多少。

Ø数据查询界面优化，默认可显示服务器和时间戳全部字符串

Ø乱序数据添加接口性能提高50%

3已修复的缺陷

Ø[252641]内核：不完全启动kernel进程，立即停止该进程，出现dump文件

Ø[246406]内核：当存储大量数据时，查询操作经常会超时

Ø[251248]Excel批量上传能创建同名Tag点

Ø[254330]报警服务内存泄漏

Ø[253931]历史记录查询：同名的tag点删除后又添加,类型显示不对

Ø[252091]标准版本升级后about显示版本未更新，如从2.1.1升级到2.2.0，帮助中版本显示仍是2.1.1

Ø[251687]采集器配置：干净Windows环境中，单独安装采集端，缺少qt库文件

Ø修复"复件 Kernel_4.txt"类型文件名影响数量判断导致大量日志

4解决的用户反馈

Ø[0002856]Excel上传Tag点，会将同名Tag点导入

Ø[0002937]大批量存储数据过程中，比如每次4000点每秒调用API一次性存储，容易导致111157错误

Ø[0003012]集群系统切换时多了iHD停机记

Ø[0002914]转储关系数据库后台运行时，执行转储时经常报错119611

Ø[0002936]如果统计点设置的初始时间较早，容易导致统计点工作异常缓慢

Ø[0002922]统计点和计算点未考虑普通点停机记录的处理

Ø[0002923]配置大批量计算点后，大部分计算点无法工作

Ø[0002910]实时数据库使用新版本的hdrda, BS中的组态页面无法获取实时值

Ø[0002886]iHD插件，在自定义属性中闪退

5已知问题与限制

ID | 描述 | 等级 | 规避措施
247893 | 权限：Tag修改者，Tag创建者都为admin | 3 | 显示的用户与创建的不一致，不影响权限验证
254180 | Excel中使用历史查询，更改excel中单元格属性，会导致已查询到的数据更改显示为“不合法的起始时间” | 4 | 单元格属性不能随意修改格式，用户手册中说明
257067 | 计算：名称为数字的tag点表达式显示有误 | 3 | Tag命名不使用数字开头
254221 | 网络：稳定性环境中，配置报警1W个点后，NetMgr占用1.6G内存 | 3 | 大量报警性能处理后续优化
257065 | SPC：当LCL在CL-sigma及CL-2sigma线上，判异5，6，7，8有问题 | 3 | 提供后续补丁修复该判异问题
257058 | 多次打开某一管理工具，最好能做个校验，只要打开一个就行了 | 4 | 后续增加独立进程检测
256955 | 分组数据同步：服务器中已经删除的Tag点在Tag分组管理的点列表中仍然可以看到 | 3 | 将开发分组数据同步
249826 | 采集器：变更tag属性，重连周期未到，采集不到数据 | 4 | 变更配置后重启采集器进程或服务
256991 | SPC: 建议与SPC报警点关联的普通点不能删除 | 4 | 删除关联普通点后可以手工添加新的
237791 | 转储服务:出现输入Q而无法退出的情况 | 4 | 可使用强制退出进程脚本退出
256708 | SPC: 报警查看界面布局不合理 | 4 | 后续版本界面优化
250671 | 分组：配置了Tag分组，当分组下有1W点时，显示较慢 | 4 | 后续优化性能
252830 | 使用ESC键，打开的当前iHD程序窗口会退出 | 4 | 操作习惯问题
253898 | 计算：if(0) then('Tag1') else('Tag2')非执行语句中，时间戳和数据质量处理方式不一致 | 4 | 未过滤不执行语句的记录，不影响实际计算结果
248020 | 安装：在安装完成界面，勾选“启动服务（立即重启计算机）”灰化 | 4 | 已经灰化，勾选不影响实际效果
247907 | 报警导出：建议硬盘快满，导出不完整时有提示 | 4 | 可导出到硬盘空间够的硬盘
240374 | OPC冗余: 新配置Tag，不能及时自动采集 | 4 | 配置后重启采集器进程或服务
249826 | 采集器：变更tag属性，重连周期未到，采集不到数据 | 4 | 有时采集器配置不能自动更新，需重启采集器进程或服务
250146 | Excel插值：函数参数，TagName框中输入Tag名后，Tag名未自动加双引号。 | 4 | 某些字符串不会自动加""，是excel自动做的，插件无法修改.一般使用单元格选择tag名不会遇到这个问题.
249568 | 报警查看注释问题 | 4 | 报警注释添加成功的提示不正确
249512 | 组态有时运行态不能F7退出 | 4 | 检查ZtDesign或Ztrun是否未正常退出，手工杀掉进程。
222413 | 冗余：有冗余机下线时，需要重连才能正常操作 | 4 | 后续改进。暂时重新连接。
223635 | 冗余：配置了冗余之后，且服务器名为中文，无法修改管理权限 | 4 | 后续改进，服务器名需要修改为英文。
222926 | 宽表转储：小数点位数被截断 | 4 | 支持脚本转储，用户通过自定义实现
223737 | 记录：浮点型（float32，float64）上传超范围值，框架中显示为inf，excel中显示的数值也不正确。建议超范围值截断或不能上传。 | 4 | 极限情况，一般工控数据不会超过float64的量程。此种情况一般是传感器故障，应该检查硬件。
223791 | excel中tag下载-tag查询-高级查询，用记录取值范围进行等于查询，记录取值范围=2147483904，查询为空 | 4 | 取值范围溢出，后续考虑在前台加校验进行规避
223795 | 在历史存储记录界面（时间区间模式），按ctrl+/进入修改状态，修改数组函数的Tag名（从有2条记录的Tag1改为只有1条记录的Tag2），并完成修改，显示两条一样的记录，不是有一条显示N/A | 4 | 不影响使用。如果有一样的记录，后续记录忽略。
225236 | 在Excel中，设置判断条件为LT(-1.1E-10)，且对应源Tag为数值型(浮点型：float32,float64)，设置值为-0.00000000012，没有进行报警 | 4 | 被截断，后续版本改进

6升级说明

6.1升级范围

组件（或节点） | 必须升级 | 推荐升级 | 不需要升级 | 其他影响
内核/服务端 | ? |  |  |
客户端 | ? |  |  |
采集器端 | ? |  |  | 2.2.0之前配置的采集器，如果升级的话，由于升级前的opcint服务会自动启动，如果需要使用新的采集器配置方式，需要手工删除老的opcint服务，重新配置保存。
资源管理服务（Tag变量分组） | ? |  |  |

6.2升级方法

1?从2.0.0以及更高版本升级

直接运行iHyperDBSetup.exe文件，选择升级安装。


2.3.0

2.3.0

1新增功能特性

Ø客户端支持Windows8 64位操作系统

Ø服务端支持Windows Server 2012 64位操作系统

Ø提供ODBC接口查询功能

Ø增加COM接口查询功能，可在iCV和iFix组态脚本中使用。

Sub page_OnLoad()

Set hdCOM = CreateObject("hdCOMInterface.hdCOMClass.1")

szIP = "192.168.128.111"

nPort = 5678

nTimeOut = 3

ret = 0

End Sub

'测试连接

Function test_create_new_connection()

ret = hdCOM.com_nt_connect(szIP, nPort, nTimeOut, hserver)

MsgBox(ret)

ret = hdCOM.com_nt_disconnect(hserver)

MsgBox(ret)

End Function

Ø提供OPCServer发布数据功能

Øtag分组服务中的tag点的描述信息能从iHD中进行同步

ØTag分组管理支持SPC报警点

ØExcel中Tag变量分组导入导出支持处理SPC报警点

Ø报警分组能在Excel中导入导出

Ø客户端进程支持安装为服务（数据库备份恢复、关系数据库转储和采集）

Ø组态选点增加支持计算点

Ø组态回放控件的参数可以通过VBS/VBA脚本进行设置，具体脚本参考用户手册

Ø统计点增加极差、标准差统计功能

ØAPI乱序数据接口支持实时报警

ØAPI新增批量获取tagid、批量查询基本属性等接口，具体参见SDK用户手册和二次开发包的hdAPI.h

2增强或变化的功能特性

Ø安装程序客户端和服务端分开，用户可根据需要选择安装。

CS安装包有如下几个可选：
iHyperDB_Server.exe 服务端，一般安装在独立服务器；
iHyperDB_Client.exe 客户端（包含采集器），一般安装在工作站和采集端前置机等；
userhelp.chm 用户手册，独立文档，如与上面exe文件放在同一个文件夹内就可以安装到程序所在目录方便后续浏览；
iDispatchServer.exe 组态节点配置分发服务，如使用组态功能就需要在服务端上再安装这个exe；
iHD_OPCServer.exe，如需使用OPC Server数据发布服务功能，则在客户端安装后再安装这个exe；
hdCOMInterface.exe，如需使用 COM组件接口，则在调用接口的工作站上安装这个exe。

iCV插件包含一个
iCV_iHDPluginSetup.exe，在icv客户端机器上安装这个exe。

Ø提供64位程序，仅提供服务端，50万点规模以上的系统使用可提高性能。
iHyperDB_Server_x64.exe 服务端
iDispatchServer_x64.exe 组态节点配置分发服务

Ø2小时试用许可证增加组态和SPC的支持

Ø采集器默认使用服务端时间戳，原来是设备时间戳，可通过采集器配置工具修改

Øopc配置时分组可以按照扫描频率配置后内部自动分组

ØTag变量添加时默认过滤超时5分钟

Ø添加SPC报警点的源点根据统计类型显示不同的控制图方式

ØAPI查询区间的记录数支持时间到毫秒

ØAPI和Buffer的进程间通信大小由4M修改为64M

ØBuffer性能优化

Ø系统信息采集周期最小30秒

Ø服务端管理工具显示速度优化

Ø配置与存数据分开，提高内核性能

Ø内核乱序数据插入性能优化

Ø翻页查询点性能优化

ØTag变量分组查询性能优化

易用性改进

Ø服务端管理工具显示安装程序版本信息

Øopc采集器能支持不用配置信任IP，而是通过实时数据库的用户名和密码进行登录

ØExcel批量上传点的进度条

3已修复的缺陷

Ø[259718]opc采集器内存泄漏

Ø硬件许可证内存泄漏问题

Ø[259219]netmgr对权限命令处理有内存泄漏

Ø[257919]老版本升级，增加的系统信息点，向后查询历史记录时，查询不到记录。

Ø[259740]内核服务起不来，出现kernel minidump，内核处理stringh和blob类型有缓冲区异常

Ø[250671]分组配置：配置了Tag分组，当分组下有1W点时，显示较慢

Ø[260545]buffer: 性能不够，来不及处理数据，断网丢数据

Ø[256903]关闭采集器（命令行窗口），opc服务端还是会保留有采集器连接

Ø[259787]多次安装时反复写环境变量path

Ø[259799]升级安装时，之前没有安装过的模块不能进行安装，必须卸载再重新装

Ø[260222]安装时环境变量path过长会清空所有path

Ø[259216]配置分发：重新安装了分发服务后，无法再次导入组态画面

Ø[259218]配置分发：iHD+iWV，组态编辑，选点弹出的是iCV的选点界面，而不是iHD的选点界面

Ø[259162]服务端管理工具：停hdNetMgr，少关联了hdSysInfoSvc的依赖关系

Ø[257831]服务端管理工具：进程启动时，会自动弹黑窗口，且不会自动隐藏

Ø[257065]SPC报警：当LCL在CL-sigma及CL-2sigma线上，判异5，6，7，8有问题

Ø[258229]关系库转储配置SPC报警点提示问题

Ø[259676]系统管理工具：OPC采集器配置页，添加采集器框中有“？”，建议去掉

Ø[258837]系统管理工具：许可证过期，重启服务后，在框架里重新连接服务器时，框架响应慢

Ø[249685]系统管理工具：断网重连后，刷新实时记录，断网提示过多

Ø[257067]计算点：名称为数字的tag点表达式显示有误

Ø[259723]报警服务占用CPU较高，由于报警服务启动比kenerl等启动快，导致报警服务一直报错

Ø[259686]Excel下载Tag有误时，弹出的错误提示框中未给出错误码信息

Ø[249568]报警查看界面注释失败，没有弹出错误提示框

Ø[259086]SPC配置客户端停止工作，数据库初次安装失败，多次安装导致数据库内容重复，后来恢复了数据库，记录为空，没做判断导致异常

Ø[259729] 分组： 查询结果为空时，无提示

Ø[258820]分组：100w点初次进入分组查询界面，查询分组变量，时间超过30s

Ø[250671]分组：配置了Tag分组，当分组下有1W点时，显示较慢

Ø[256955]分组数据同步： 服务器中已经删除的Tag点在Tag分组管理的点列表中仍然可以看到

Ø[259724]分组：在变量分组配置中，未给出超时提示

4解决的用户反馈

Ø[0001955]不支持SQL语句查询，查询数据灵活性不高

Ø[0003025]关闭采集器是没有关闭opc连接

5已知问题与限制

ID | 描述 | 等级 | 规避措施
247893 | 权限：Tag修改者，Tag创建者都为admin | 3 | 显示的用户与创建的不一致，不影响权限验证
254180 | Excel中使用历史查询，更改excel中单元格属性，会导致已查询到的数据更改显示为“不合法的起始时间” | 4 | 单元格属性不能随意修改格式，用户手册中说明
254221 | 网络：稳定性环境中，配置报警1W个点后，NetMgr占用1.6G内存 | 3 | 大量报警性能处理后续优化
249826 | 采集器：变更tag属性，重连周期未到，采集不到数据 | 4 | 变更配置后重启采集器进程或服务
256991 | SPC: 建议与SPC报警点关联的普通点不能删除 | 4 | 删除关联普通点后可以手工添加新的
237791 | 转储服务:出现输入Q而无法退出的情况 | 4 | 可使用强制退出进程脚本退出
256708 | SPC: 报警查看界面布局不合理 | 4 | 后续版本界面优化
252830 | 使用ESC键，打开的当前iHD程序窗口会退出 | 4 | 操作习惯问题
253898 | 计算：if(0) then('Tag1') else('Tag2')非执行语句中，时间戳和数据质量处理方式不一致 | 4 | 未过滤不执行语句的记录，不影响实际计算结果
248020 | 安装：在安装完成界面，勾选“启动服务（立即重启计算机）”灰化 | 4 | 已经灰化，勾选不影响实际效果
247907 | 报警导出：建议硬盘快满，导出不完整时有提示 | 4 | 可导出到硬盘空间够的硬盘
240374 | OPC冗余: 新配置Tag，不能及时自动采集 | 4 | 配置后重启采集器进程或服务
249826 | 采集器：变更tag属性，重连周期未到，采集不到数据 | 4 | 有时采集器配置不能自动更新，需重启采集器进程或服务
250146 | Excel插值：函数参数，TagName框中输入Tag名后，Tag名未自动加双引号。 | 4 | 某些字符串不会自动加""，是excel自动做的，插件无法修改.一般使用单元格选择tag名不会遇到这个问题.
249512 | 组态有时运行态不能F7退出 | 4 | 检查ZtDesign或Ztrun是否未正常退出，手工杀掉进程。
222413 | 冗余：有冗余机下线时，需要重连才能正常操作 | 4 | 后续改进。暂时重新连接。
223635 | 冗余：配置了冗余之后，且服务器名为中文，无法修改管理权限 | 4 | 后续改进，服务器名需要修改为英文。
222926 | 宽表转储：小数点位数被截断 | 4 | 支持脚本转储，用户通过自定义实现
223737 | 记录：浮点型（float32，float64）上传超范围值，框架中显示为inf，excel中显示的数值也不正确。建议超范围值截断或不能上传。 | 4 | 极限情况，一般工控数据不会超过float64的量程。此种情况一般是传感器故障，应该检查硬件。
223791 | excel中tag下载-tag查询-高级查询，用记录取值范围进行等于查询，记录取值范围=2147483904，查询为空 | 4 | 取值范围溢出，后续考虑在前台加校验进行规避
223795 | 在历史存储记录界面（时间区间模式），按ctrl+/进入修改状态，修改数组函数的Tag名（从有2条记录的Tag1改为只有1条记录的Tag2），并完成修改，显示两条一样的记录，不是有一条显示N/A | 4 | 不影响使用。如果有一样的记录，后续记录忽略。
225236 | 在Excel中，设置判断条件为LT(-1.1E-10)，且对应源Tag为数值型(浮点型：float32,float64)，设置值为-0.00000000012，没有进行报警 | 4 | 长度过长的被截断，后续版本改进

6升级说明

6.1升级范围

组件（或节点） | 必须升级 | 推荐升级 | 不需要升级 | 其他影响
内核/服务端 | ? |  |  |
客户端 | ? |  |  |
采集器端 | ? |  |  | 2.2.0以前版本如果安装过hdOpcInt采集器服务，需先手工sc delete hdopcint删除，用新的采集器配置工具来配置和安装服务，保存配置后重新启动采集器。
资源管理服务（Tag变量分组） | ? |  |  |

6.2升级方法

1.从2.0.0以及更高版本升级

直接在对应机器上运行安装程序文件，选择升级安装。

注：采集器端运行前需使用采集器配置工具重新勾选本地应用保存和启动。


2.4.1

2.4.1

1新增功能特性

1.1系统

Ø客户端国际化支持简体中文和英文系统，安装程序exe提供2份，安装后显示对应语言。

Ø服务端支持HPUX 64位系统。

1.2内核

Ø存储数据多分区的支持：物理上多块硬盘，原来Data目录下包含的序列缓存、块缓存、归档文件、实时报警等内容可存储在不同目录或硬盘分区。

1.3统计计算

Ø统计点采样模式支持线性插值和前向插值，统计计时支持时间追溯和持续统计，新增数据过滤功能（对不满足条件的数据进行过滤，过滤条件支持表达式）。

Ø计算表达式增加极大值过滤函数: FilExtream('srctag',calctag,5,50)

Ø计算点表达式支持统计点作为源点

Ø统计点的统计监测点支持计算点

1.4工具

ØOPC采集器配置工具可以直接浏览OPCServer，批量选点导出为xls格式，直接通过excel上传加点

Ø增加客户端连接监测工具。

1.5接口

ØODBC SQL查询时支持max,min,average,count,sum几个内置函数功能。

ØODBC接口支持C#调用

ØC++API：增加字符编码格式设置接口ut_set_charset，connect接口支持域名访问实时数据库。

ØC# SDK：增加乱序数据插入的接口saveDisorderSnapshots和saveTagsDisorderSnapshots，获取连接并登陆的接口getHDDataConnection和报警点配置，具体参见iHDSDKdoc.chm。

ØJAVA SDK：新增乱序写数据、修改原始值、报警点配置、批量插值查询接口，可以自行指定插值时间、获取连接并登陆的接口，具体参见iHDSDKdoc.chm。

2增强或变化的功能特性

Ø安装程序改进:增加hdSetup.exe安装向导工具，加载同目录下所有可安装的程序，如果有多个模块安装，自动识别安装的先后顺序（服务端和客户端安装一般先启动）.注意勾选多个模块安装的过程可能有若干重启提示,安装中间过程可不重启，全部安装完成后重启;当前中间过程计算机重启后不会自动运行hdSetup，需要手工重新运行，但会记录已经安装过的组件,在界面可查看已安装模块。

ØiCV获取实时数据库插件通过iCV的安装程序选择安装（需先将发布的ext.icvhdplugin-5.5.4.zip拷贝到iCV的icv-win32-5.5.4.619-bin.7z解压后的packages目录,执行iCV的install.exe，界面应有插件的选项可勾选）,插件安装后路径为executable\ztplugins\ihd，与2.3版本不一样了。

Ø来自iCV组态的客户端连接不占用许可证中的客户端连接数。

Ø过滤未来时间戳数据：当前OPC采集器打时间戳是可以配置服务端时间同步，也可以是保持设备时间戳，但如果个别设备时间错误导致存储进来的数据时间戳超过了服务器端时间比较多，则对业务应用会有较大的影响，因此需要在服务器端进行配置，增加数据时间戳过滤时间（指时间戳超过服务器端时间大于此时间范围的数据，将会被丢弃），默认值为30分钟，可通过服务端管理工具修改配置。

Ø服务端管理工具优化：

o进程退出要优雅退出不要直接taskkill强制中止，考虑进程间通讯正常退出。

o服务端内核在第一次启动时，比较慢，希望能在正常启动后，显示正在运行，之前的状态为正在启动。

o可显示当前已使用的Tag点数

ØTAG权限配置界面调整：创建Tag点权限下拉选项修改为有和无(有对应原来的读/写，无对应原来的只读）。

Ø错误日志细化：Excel上传加点出错时的错误码细化，经常由于采集器 扫描组等未配置正确，导致添加点失败，但提示都是sqlite中未查询到记录；采集器日志中的save_snapshot失败的原因细化。

ØhdAPI增加日志方便定位问题

Ø组态历史数据回放性能优化,一个画面2000点规模支持回放间隔1s

易用性改进

Ø系统管理工具中的Tag点配置-设备点名可以从OPCServer中浏览并自动填写

ØOPC采集器配置：设备名称可以直接通过OPC标准接口浏览后选择，直持本地和远程（需先配置DCOM）。

ØOPC采集器增量配置优化，避免修改配置需要重启。

Ø组态节点分发配置中的勾选或点亮操作逻辑一致方便操作。

Ø转储改进：当转到关系库的数据被清除后，转储重启后不要按照原始配置进行转储，自动使用上次转储的时间.

3已修复的缺陷

Ø[266746]组态：组态回放不能控制弹出页面的其他tag点进行回放

Ø[266730]内核: 当配置数据文件大于4G时，当数据量超过4G时，无法正确查询到数据，提示110350

Ø[261074]安装：采集端升级后，强制将客户端也装上了

Ø[261079]OPC发布：在iCVOPC驱动中，无法读到iHD OPCServer发布的点

Ø[261460]opc: 增删改采集器对应的点会影响在线响应

Ø[262374]采集时，修改tag，同采集器下所有采集点全部刷新

Ø[261479]iCV插件： 趋势图中，有ihd点记录值无法读取

Ø[261654]安装64位服务端到全新的64位机器上时出错

Ø[261695]OPC采集器配置：Excel正在上传Tag点的同时，添加采集器设备失败，但弹出的提示框却显示成功

Ø[262841]win7环境下：odbcsql查询，生成where语句里ftime的格式问题

Ø[263035]权限：批量加点接口未实现Tag创建权限

Ø[263133]组态：拔网线导致的组态崩溃

Ø[263309]Buffer：buffer停止工作，重新启动后，会发生数据错乱现象

Ø[263378]win7(64位)：db菜单进入odbc数据源管理器，无法获取db的驱动

Ø[263644]采集器：64位英文版安装多个采集器服务，会提示冲突

Ø[263379]框架：未选服务器，查询tag时选“全选所有页”，有出错提示

Ø[265379]采集：已使用的采集器、设备、扫描组，要限制不能删除。

Ø[265805]用户手册：示例代码中缺少ca_query_tag_name

Ø[265818]用户手册：Digitalset管理接口 > pt_modify_digitalset：示例函数中缺少参数

Ø[265821]用户手册：ct_query_device_status_rec的示例代码是ct_query_collector_status_rec

4解决的用户反馈

Ø[0001964]创建TAG点时，功能较弱，不支持在线搜索所有OPC数据，不能带出OPC的变量类型

Ø[0002902]系统管理工具，新增Tag点，配置Tag点的属性时，设备点名目前是手动输入，用户希望可选

Ø[0003130]永久有效许可证的正确显示

Ø[0003121]趋势图一段时间内tag点无数据影响后续

Ø[0003120]数据插值查询失败，导致趋势数据无法显示

5已知问题与限制

ID | 描述 | 等级 | 规避措施
266919 | 组态：faq:建议iCV组态支持iHD的Tag名的合法特殊字符 -:.()[]+=%@# | 4 | 需要组态显示的ihd数据点,需要符合icv点名称规则
266770 | 统计点：建点时遇到连接超时，前台框架没法重新建该点，报该点已存在，但实际查不到该点 | 3 | 使用新的Tag名创建或者联系支持人员手工修正配置库
266358 | 计算点极大值过滤，时间间隔为0、非整数，负数，输入有些数据，框架没有校验（阈值也是） | 3 | 计算表达式输入界面不做复杂限制，配置时需注意，如果计算点未正确计算请先检查配置
266918 | 安装：hdSetup建议一键安装，可以在分布列出的每个模块后面增加安装按钮，避免误解 | 4 | 安装过程如果重启计算机，建议重启后运行hdSetup确认是否安装成功
260850 | opc采集超时更新问题：设备和服务器时间不一致，时间戳选择设备，状态点显示为一条超时一条活动 | 4 | 调整设备或DCS时间与服务器时间一致
266790 | 转储：出现转储数据后，HDExport.xml中未写入当前转储时间的情况 | 3 | 转储进程方式运行时退出会导致当前转储时间未写入配置文件,推荐安装为服务运行
247893 | 权限：Tag修改者，Tag创建者都为admin | 3 | 显示的用户总是admin,与创建的不一致，但不影响权限验证
266795 | 分发：配置分发不支持域名 | 3 | 组态配置分发需要配置实际IP地址
259143 | Odbcsql界面查看，增删数据源或修改数据源名称后，odbcsql里的数据源名称不会自动刷新 | 4 | 修改系统ODBC配置后需重新打开SQL查询窗口进行查询
254180 | Excel中使用历史查询，更改excel中单元格属性，会导致已查询到的数据更改显示为“不合法的起始时间” | 4 | 单元格属性不能随意修改格式，用户手册中说明
254221 | 网络：稳定性环境中，配置报警1W个点后，NetMgr占用1.6G内存 | 3 | 大量报警性能处理后续优化
256991 | SPC: 建议与SPC报警点关联的普通点不能删除 | 4 | 删除关联普通点后可以手工添加新的
237791 | 转储服务:出现输入Q而无法退出的情况 | 4 | 可使用强制退出进程脚本退出
256708 | SPC: 报警查看界面布局不合理 | 4 | 后续版本界面优化
252830 | 使用ESC键，打开的当前iHD程序窗口会退出 | 4 | 操作习惯问题
253898 | 计算：if(0) then('Tag1') else('Tag2')非执行语句中，时间戳和数据质量处理方式不一致 | 4 | 未过滤不执行语句的记录，不影响实际计算结果
248020 | 安装：在安装完成界面，勾选“启动服务（立即重启计算机）”灰化 | 4 | 已经灰化，勾选不影响实际效果
247907 | 报警导出：建议硬盘快满，导出不完整时有提示 | 4 | 可导出到硬盘空间够的硬盘
250146 | Excel插值：函数参数，TagName框中输入Tag名后，Tag名未自动加双引号。 | 4 | 某些字符串不会自动加""，是excel自动做的，插件无法修改.一般使用单元格选择tag名不会遇到这个问题.
249512 | 组态有时运行态不能F7退出 | 4 | 检查ZtDesign或Ztrun是否未正常退出，手工杀掉进程。
222413 | 冗余：有冗余机下线时，需要重连才能正常操作 | 4 | 后续改进。暂时重新连接。
223635 | 冗余：配置了冗余之后，且服务器名为中文，无法修改管理权限 | 4 | 后续改进，服务器名需要修改为英文。
222926 | 宽表转储：小数点位数被截断 | 4 | 支持脚本转储，用户通过自定义实现
223737 | 记录：浮点型（float32，float64）上传超范围值，框架中显示为inf，excel中显示的数值也不正确。建议超范围值截断或不能上传。 | 4 | 极限情况，一般工控数据不会超过float64的量程。此种情况一般是传感器故障，应该检查硬件。
223791 | excel中tag下载-tag查询-高级查询，用记录取值范围进行等于查询，记录取值范围=2147483904，查询为空 | 4 | 取值范围溢出，后续考虑在前台加校验进行规避
223795 | 在历史存储记录界面（时间区间模式），按ctrl+/进入修改状态，修改数组函数的Tag名（从有2条记录的Tag1改为只有1条记录的Tag2），并完成修改，显示两条一样的记录，不是有一条显示N/A | 4 | 不影响使用。如果有一样的记录，后续记录忽略。
225236 | 在Excel中，设置判断条件为LT(-1.1E-10)，且对应源Tag为数值型(浮点型：float32,float64)，设置值为-0.00000000012，没有进行报警 | 4 | 长度过长的被截断，后续版本改进

6升级说明

6.1升级范围

组件（或节点） | 必须升级 | 推荐升级 | 不需要升级 | 其他影响
内核/服务端 | ? |  |  |
客户端 | ? |  |  |
采集器端 | ? |  |  | 2.2.0以前版本如果安装过hdOpcInt采集器服务，需先手工sc delete hdopcint删除，用新的采集器配置工具来配置和安装服务，保存配置后重新启动采集器。
资源管理服务（Tag变量分组） | ? |  |  |

6.2升级方法

1.从2.0.0以及更高版本升级

直接在对应机器上运行安装程序文件，选择升级安装。

注意：

1）iCVBS Server使用iHD插件需要重新上传web升级包。

2）采集器配置的OPC设备需重新选择配置机器名。


2.4.2

2.4.2

1新增功能特性

1.1系统

Ø服务端支持Solaris 11 sparc系统（不包含分组和组态分发服务）。

Ø客户端提供windows 64位编译版本（不包含组态和OPC相关功能），支持64位excel程序插件。

1.2配置

Ø增加授权项管理功能，可以在组态中使用脚本验证登陆用户是否具有某授权项。具体使用参见用户手册：功能明细>数据展示>组态展示>授权项脚本

1.3统计计算

Ø计算点表达式增加函数TagHour等支持获取Tag记录时间。具体参见用户手册

功能明细>数据源配置>计算点 ,b、内置函数

1.4采集

Ø增加支持iHD服务端到服务端采集器。

1.5接口

Ø增加支持Python2.7接口。

ØSDK增加多点插值查询接口，具体参见iHDSDKdoc.chm。

2增强或变化的功能特性

ØODBCSQL查询支持tag数据类型的字段。

Ø提供iCVBS发布需要的插件压缩包ext.hd4icvbs-5.5.4.zip。

易用性改进

ØhdSetup总体安装支持记录安装进度，重启后自动运行hdSetup选择继续安装。

3已修复的缺陷

Ø[268557]权限配置“无”选择时配置错误

Ø[269756]组态分发：组态功能里，子文件夹下画面签出签入有问题

Ø[269948]组态分发: 启动ztdesign频率过高，导致系统管理工具无响应

Ø[269764]ODBC SQL查询配置时间可设置开始时间大于结束时间

Ø[270756]odbc 查询：select十列内置函数查询时异常

Ø[270133]pt_add_tags接口内部错误码数组未初始化

Ø[267130]插值查询,压缩打开时,snapshot与前一条记录之间插值时插值记录值不正确

Ø[269758]插值：希望good和停机记录间，能插值到最后一条good记录时刻的记录

Ø[254221]报警雪崩时客户端处理报警比较慢导致网络服务内存占用很多

Ø[270762]关系库采集器配置,删除表映射 会删除系统id=0默认设备，导致查不到系统点和icg采集的点

Ø[269783]OPC远程配置iCV OPCServer发布的点不行

ØOPC配置内存泄露

ØSPC报警点配置的内存泄露

ØExcel插件英文版提示有乱码

Ø插值查询在当前缓存文件无数据时会返回比快照时间晚的数据

4解决的用户反馈

Ø0003162采集端停机记录前一条插值记录取最后一次的原始值

Ø0003153历史记录和实时纪录之间插值

Ø0003160组态功能里，子文件夹下画面签出签入有问题

Ø0003161ihd选点，无法通过dcom选择icv的opcserver的点

Ø0003163趋势图显示未来插值记录

5已知问题与限制

ID | 描述 | 等级 | 规避措施
266919 | 组态：faq:建议iCV组态支持iHD的Tag名的合法特殊字符 -:.()[]+=%@# | 4 | 需要组态显示的ihd数据点,需要符合icv点名称规则
271080 | 转储：转储配置在线更新问题 | 3 | 修改转储配置后重启转储后台服务
266770 | 统计点：建点时遇到连接超时，前台框架没法重新建该点，报该点已存在，但实际查不到该点 | 3 | 使用新的Tag名创建或者联系支持人员手工修正配置库
266358 | 计算点极大值过滤，时间间隔为0、非整数，负数，输入有些数据，框架没有校验（阈值也是） | 3 | 计算表达式输入界面不做复杂限制，配置时需注意，如果计算点未正确计算请先检查配置
266918 | 安装：hdSetup建议一键安装，可以在分布列出的每个模块后面增加安装按钮，避免误解 | 4 | 安装过程如果重启计算机，建议重启后运行hdSetup确认是否安装成功
260850 | opc采集超时更新问题：设备和服务器时间不一致，时间戳选择设备，状态点显示为一条超时一条活动 | 4 | 调整设备或DCS时间与服务器时间一致
266790 | 转储：出现转储数据后，HDExport.xml中未写入当前转储时间的情况 | 3 | 转储进程方式运行时退出会导致当前转储时间未写入配置文件,推荐安装为服务运行
247893 | 权限：Tag修改者，Tag创建者都为admin | 3 | 显示的用户总是admin,与创建的不一致，但不影响权限验证
266795 | 分发：配置分发不支持域名 | 3 | 组态配置分发需要配置实际IP地址
259143 | Odbcsql界面查看，增删数据源或修改数据源名称后，odbcsql里的数据源名称不会自动刷新 | 4 | 修改系统ODBC配置后需重新打开SQL查询窗口进行查询
254180 | Excel中使用历史查询，更改excel中单元格属性，会导致已查询到的数据更改显示为“不合法的起始时间” | 4 | 单元格属性不能随意修改格式，用户手册中说明
256991 | SPC: 建议与SPC报警点关联的普通点不能删除 | 4 | 删除关联普通点后可以手工添加新的
237791 | 转储服务:出现输入Q而无法退出的情况 | 4 | 可使用强制退出进程脚本退出
256708 | SPC: 报警查看界面布局不合理 | 4 | 后续版本界面优化
252830 | 使用ESC键，打开的当前iHD程序窗口会退出 | 4 | 操作习惯问题
253898 | 计算：if(0) then('Tag1') else('Tag2')非执行语句中，时间戳和数据质量处理方式不一致 | 4 | 未过滤不执行语句的记录，不影响实际计算结果
248020 | 安装：在安装完成界面，勾选“启动服务（立即重启计算机）”灰化 | 4 | 已经灰化，勾选不影响实际效果
247907 | 报警导出：建议硬盘快满，导出不完整时有提示 | 4 | 可导出到硬盘空间够的硬盘
250146 | Excel插值：函数参数，TagName框中输入Tag名后，Tag名未自动加双引号。 | 4 | 某些字符串不会自动加""，是excel自动做的，插件无法修改.一般使用单元格选择tag名不会遇到这个问题.
249512 | 组态有时运行态不能F7退出 | 4 | 检查ZtDesign或Ztrun是否未正常退出，手工杀掉进程。
222413 | 冗余：有冗余机下线时，需要重连才能正常操作 | 4 | 后续改进。暂时重新连接。
223635 | 冗余：配置了冗余之后，且服务器名为中文，无法修改管理权限 | 4 | 后续改进，服务器名需要修改为英文。
222926 | 宽表转储：小数点位数被截断 | 4 | 支持脚本转储，用户通过自定义实现
223737 | 记录：浮点型（float32，float64）上传超范围值，框架中显示为inf，excel中显示的数值也不正确。建议超范围值截断或不能上传。 | 4 | 极限情况，一般工控数据不会超过float64的量程。此种情况一般是传感器故障，应该检查硬件。
223791 | excel中tag下载-tag查询-高级查询，用记录取值范围进行等于查询，记录取值范围=2147483904，查询为空 | 4 | 取值范围溢出，后续考虑在前台加校验进行规避
223795 | 在历史存储记录界面（时间区间模式），按ctrl+/进入修改状态，修改数组函数的Tag名（从有2条记录的Tag1改为只有1条记录的Tag2），并完成修改，显示两条一样的记录，不是有一条显示N/A | 4 | 不影响使用。如果有一样的记录，后续记录忽略。
225236 | 在Excel中，设置判断条件为LT(-1.1E-10)，且对应源Tag为数值型(浮点型：float32,float64)，设置值为-0.00000000012，没有进行报警 | 4 | 长度过长的被截断，后续版本改进

6升级说明

6.1升级范围

组件（或节点） | 必须升级 | 推荐升级 | 不需要升级 | 其他影响
内核/服务端 | ? |  |  |
客户端 | ? |  |  |
采集器端 | ? |  |  | 2.2.0以前版本如果安装过hdOpcInt采集器服务，需先手工sc delete hdopcint删除，用新的采集器配置工具来配置和安装服务，保存配置后重新启动采集器。
资源管理服务（Tag变量分组） | ? |  |  |

6.2升级方法

1.从2.0.0以及更高版本升级

直接在对应机器上运行安装程序文件，选择升级安装。

注意：

1）iCVBS Server使用iHD插件需要重新上传web升级包。

2）采集器配置的OPC设备需重新选择配置机器名。


2.4.3

2.4.3

1新增功能特性

1.1Excel客户端统计

历史数据的客户端统计功能

1.2采集

Modbus采集器：支持modbusTCP/RTU/串口三种类型。

OPC采集器配置工具支持一次性获取所有符合条件的item

采集端的数据过滤压缩功能

1.3组态控件

实时报警控件

柱状图

饼图

1.4接口

javaSDK增加实时报警接口,具体参见SDK帮助手册.

1. publicHDAlarmRecordqueryAlarmSnapshot(intnAlarmTagID, long nPropMask) throws HDSdkException

2. public Map<Integer, List<HDAlarmRecord>>queryAlarmGroupRecords(intnAlarmGroupID, HdAlarmQueryqueryCond, long nMask)

throws HDSdkException

3. public Map<Integer, HDAlarmRecord>queryAlarmSnapshots(int[] alarmTagIDs, long nMask)

throws HDSdkException

4. public void acknowledgeAlarm(intnAlarmTagID, HdTimealarmTime)

throws HDSdkException

5. public void commentAlarm( intnAlarmTagID, HdTimealarmTime, String strComment) throws HDSdkException

2增强或变化的功能特性

Tag点配置支持OPC设备点地址超过64字节（小于256字节）,相应得SDK中instrumentPoint长度由64改为256

硬件许可证支持 Windows Server 2012 R2

3已修复的缺陷

[271080]关系库转储配置在线更新失败，需重启转储进程后，才能正常转储。

[270834]API: 多线程调用api出现异常。

原因：2.4版本加入的hdapi写日志功能，在多线程情况下，倘若全局对象构造函数还未执行完成，就直接调用其中的日志输出函数的话，会导致程序异常。

[271171]安装iHyperDB2.4.2-64_BUILD_20141204 OEM版，先装服务端，再装客户端会失败。

buffer缓存中的点在服务端删除后buffer不能送数据了.

原因： API的save_snapshots对返回值判断有问题，当部分成功时直接返回了失败，错误码数组没有正确赋值，导致调用者判断有误，从而无法发送数据。

Ø[270323]0003163: 趋势图显示未来插值记录。

现象：对于数据的插值，如果选择未来时间，应该没有插值记录；但实际在未来时间有插值，并在趋势图上反映出未来的趋势。

原因：插值算法对于未来时间未做校验

Ø[271407]安装：当使用opc server时，无法完成升级安装。

原因：opcserver的动态库被其他程序加载导致升级更新文件失败，需要手工退出连接opcserver的程序。

修改：安装程序先重命名dll再拷贝，避免文件无法覆盖的问题。

Ø[273038]Excel：创建并修改时，创建的点的OPC发布状态设为1不成功，仍为未发布。

Ø[273035]采集：本地服务的用户名和密码配置，说明不清楚容易误填为windows密码，实际应是连接iHD服务器的登陆用户密码。

ØOPC采集器配置,浏览opcserver通过防火墙有时异常退出。

ØExcel批量删除点比较多时可能内核异常退出。

ØExcel批量加点时采集器在线更新有遗漏，需要重启采集器才能开始采集。

Ø批量加点失败的点数也占用许可点数限制，需要重启服务端才能使用误占用的许可点数。

4解决的用户反馈

Ø0003171采集：本地服务的用户名和密码配置，说明不清楚容易误填为windows密码

Ø0003168:设备点名的长度要支持64以上

Ø0003167:关系库采集器配置,删除表映射会删除系统id=0默认设备，导致查不到系统点和icg采集的点

5已知问题与限制

ID | 描述 | 等级 | 规避措施
266919 | 组态：faq:建议iCV组态支持iHD的Tag名的合法特殊字符 -:.()[]+=%@# | 4 | 需要组态显示的ihd数据点,需要符合icv点名称规则
266358 | 计算点极大值过滤，时间间隔为0、非整数，负数，输入有些数据，框架没有校验（阈值也是） | 3 | 计算表达式输入界面不做复杂限制，配置时需注意，如果计算点未正确计算请先检查配置
266918 | 安装：hdSetup建议一键安装，可以在分布列出的每个模块后面增加安装按钮，避免误解 | 4 | 安装过程如果重启计算机，建议重启后运行hdSetup确认是否安装成功
260850 | opc采集超时更新问题：设备和服务器时间不一致，时间戳选择设备，状态点显示为一条超时一条活动 | 4 | 调整设备或DCS时间与服务器时间一致
273231 | Zt组态—饼图、柱状图：建议刷新周期不允许为0、负数和空 | 4 | 界面不做限制，配置时需注意
273229 | Zt组态—饼图、柱状图：组态编辑态中，时间配置为2015-2-29日也可以保存 | 3 | 界面不做限制，配置时需注意
266790 | 转储：出现转储数据后，HDExport.xml中未写入当前转储时间的情况 | 3 | 转储进程方式运行时退出会导致当前转储时间未写入配置文件,推荐安装为服务运行
247893 | 权限：Tag修改者，Tag创建者都为admin | 3 | 显示的用户总是admin,与创建的不一致，但不影响权限验证
266795 | 分发：配置分发不支持域名 | 3 | 组态配置分发需要配置实际IP地址
259143 | Odbcsql界面查看，增删数据源或修改数据源名称后，odbcsql里的数据源名称不会自动刷新 | 4 | 修改系统ODBC配置后需重新打开SQL查询窗口进行查询
254180 | Excel中使用历史查询，更改excel中单元格属性，会导致已查询到的数据更改显示为“不合法的起始时间” | 4 | 单元格属性不能随意修改格式，用户手册中说明
256991 | SPC: 建议与SPC报警点关联的普通点不能删除 | 4 | 删除关联普通点后可以手工添加新的
237791 | 转储服务:出现输入Q而无法退出的情况 | 4 | 可使用强制退出进程脚本退出
256708 | SPC: 报警查看界面布局不合理 | 4 | 后续版本界面优化
252830 | 使用ESC键，打开的当前iHD程序窗口会退出 | 4 | 操作习惯问题
253898 | 计算：if(0) then('Tag1') else('Tag2')非执行语句中，时间戳和数据质量处理方式不一致 | 4 | 未过滤不执行语句的记录，不影响实际计算结果
248020 | 安装：在安装完成界面，勾选“启动服务（立即重启计算机）”灰化 | 4 | 已经灰化，勾选不影响实际效果
247907 | 报警导出：建议硬盘快满，导出不完整时有提示 | 4 | 可导出到硬盘空间够的硬盘
250146 | Excel插值：函数参数，TagName框中输入Tag名后，Tag名未自动加双引号。 | 4 | 某些字符串不会自动加""，是excel自动做的，插件无法修改.一般使用单元格选择tag名不会遇到这个问题.
249512 | 组态有时运行态不能F7退出 | 4 | 检查ZtDesign或Ztrun是否未正常退出，手工杀掉进程。
222413 | 冗余：有冗余机下线时，需要重连才能正常操作 | 4 | 后续改进。暂时重新连接。
223635 | 冗余：配置了冗余之后，且服务器名为中文，无法修改管理权限 | 4 | 后续改进，服务器名需要修改为英文。
222926 | 宽表转储：小数点位数被截断 | 4 | 支持脚本转储，用户通过自定义实现
223737 | 记录：浮点型（float32，float64）上传超范围值，框架中显示为inf，excel中显示的数值也不正确。建议超范围值截断或不能上传。 | 4 | 极限情况，一般工控数据不会超过float64的量程。此种情况一般是传感器故障，应该检查硬件。
223791 | excel中tag下载-tag查询-高级查询，用记录取值范围进行等于查询，记录取值范围=2147483904，查询为空 | 4 | 取值范围溢出，后续考虑在前台加校验进行规避
223795 | 在历史存储记录界面（时间区间模式），按ctrl+/进入修改状态，修改数组函数的Tag名（从有2条记录的Tag1改为只有1条记录的Tag2），并完成修改，显示两条一样的记录，不是有一条显示N/A | 4 | 不影响使用。如果有一样的记录，后续记录忽略。
225236 | 在Excel中，设置判断条件为LT(-1.1E-10)，且对应源Tag为数值型(浮点型：float32,float64)，设置值为-0.00000000012，没有进行报警 | 4 | 长度过长的被截断，后续版本改进

6升级说明

6.1升级范围

组件（或节点） | 必须升级 | 推荐升级 | 不需要升级 | 其他影响
内核/服务端 | ? |  |  |
客户端 | ? |  |  |
采集器端 | ? |  |  | 2.2.0以前版本如果安装过hdOpcInt采集器服务，需先手工sc delete hdopcint删除，用新的采集器配置工具来配置和安装服务，保存配置后重新启动采集器。
资源管理服务（Tag变量分组） | ? |  |  |

6.2升级方法

1.从2.0.0以及更高版本升级

直接在对应机器上运行安装程序文件，选择升级安装。

注意：

1）iCVBS Server使用iHD插件需要重新上传web升级包。

2）采集器配置的OPC设备需重新选择配置机器名。

3）iWebView 版本可以使用2.4.2版本对接IHyperDB的2.4.3版本。


2.4.3 P1

Navigation: 2.4.3 >

2.4.3 P1

 Return to chapter overview

1增强或变化的功能特性

Ø实时报警查看工具增加显示报警点描述。

Ø实时报警查看工具增加选择是否显示未确认已恢复的报警。

Ø关系库转储配置单个规则由限制100点增加到65535点。

Ø关系库转储服务启动和退出性能优化。

2修复的缺陷

Ø[279326]关系库转储原始值到SQLServer窄表不成功。

Ø[278065]关系库转储服务退出写配置有时不完全。

Ø[273987]关系库转储：报警点的结束时间有的未存储到数据库中。

Ø[273383]modbus采集：设备忙碌没有应答时，事务号会发生错乱导致不能采集。

Ø[273646]modbus采集：采集两个点名时出现了设备丢包。

Ø[279660]报警关联源点为digital类型不能触发。

Ø[276508]统计点监测点名字与tag名一样,导致无法从界面删除。

Ø[279470]所有模块的选点界面，选择统计点、计算点、报警点等，列表中的描述均不正确。

Ø[279659]ODBC接口查询条件合并的判断只比了值,没有比较tag点和运算符。

Ø[279661]数据源添加时Tag采集属性配置浏览远程OPC失败。

Ø[276509]一个采集端先配置一个modbus采集器，再配置一个opc采集器，启动两个采集器，opc采集器不能启动，提示读取配置文件错误。

Ø[273866]关系库采集不能使用宽表。

Ø[279662]关系库采集name字段长度限制错误导致不能进行表映射。

Ø[273857]关系库采集time字段不支持datetime类型。

Ø[279602]备份和恢复:新建一个备份恢复时，若选择已经存在备份文件的路径，则不让创建，该处理不妥。

Ø[266827]OPC采集器配置工具：OPCServer导出点时,增加前缀后缀的Tag名合法性未校验。

Ø[274028]内核：配置序列缓存大于2G（4095M），内核当一个序列缓存存满后会flush失败。

3已知问题与限制

ID | 描述 | 等级 | 规避措施
274312 | 安装：在XP系统上，无法运行hdSetup | 3 | 基础版本问题，使用独立的client和server安装程序exe可以执行，后续在2.4.4整体版本中修复。
264320 | 权限：本机登录，仍需输入用户名及密码, 导致统计点无法统计 | 3 | 重启网络服务.。因为权限模块启动时插入本地信任到kernel.db和hdkernel偶尔有冲突，统一到V3版本，同一配置服务来操作kernel.db来解决。
266770 | 统计点：建点时遇到连接超时，前台框架没法重新建该点，报该点已存在，但实际查不到该点 | 3 | 修改名称或者从kernel.db删除。因为新建统计点并不是个原子操作，从概率上存在已创建普通点但创建统计属性失败情况，统一到V3版本解决。
261468 | 安装：卸载, 自定义路径下的文件夹未被删除 | 3 | 如果确认不需要数据，可以手工删除自定义的非安装目录下的Data文件夹。
279858 | 配置点每次新增加一个tag点，都需要选择服务器 | 4 | 只配置一个服务器时可以记住上次选择的,多个服务器时需要手动切换。
279678 | 【转储】-不同周期的点配置在同一张宽表中，周期慢的点会漏 | 4 | 相同采样周期的配置在一张宽表。
279846 | 【英文版】【dispatch】分发失败错误乱码 | 4 | 个别中文提示乱码,可以根据错误码数值查询得知具体错误信息。
279853 | 【iHD2iHD】：删除采集器后，目标服务器中的系统状态点未一同删除 | 4 | 多余状态点，不影响采集功能。
280512 | iHD2iHD采集：未选中采集器，点击源点后的【选择】按钮，可以点击，但弹出界面或提示信息 | 4 | 提示信息，正常操作不影响配置功能。
280520 | iHD2iHD采集：采集器状态信息不详细 | 4 | 不影响采集功能。

4升级说明

4.1升级范围

组件（或节点） | 必须升级 | 推荐升级 | 不需要升级 | 其他影响
服务端 | ? |  |  |
客户端 | ? |  |  |
采集器端 | ? |  |  |

4.2升级方法

在安装2.4.3版本的系统上运行2.4.3P1补丁安装程序。

注意：

1.补丁版本有win32/64，中英文区别，win32中文版为win32_iHyperDB2.4.3P1.exe；

2.升级前需要退出iHD相关程序，包括iHD服务和客户端，以及使用iHD接口的应用程序，如安装插件的excle和iCV组态等。


2.4.5

2.4.5

1新增功能特性

1.1xinsight大数据平台采集器

可将实时数据库所有普通点数据转发到xinsight大数据平台

2增强或变化的功能特性

·关系库转储服务启动和退出性能优化。

·实时报警查看工具增加显示报警点描述。

·实时报警查看工具增加选择是否显示未确认已恢复的报警。

·关系库转储配置单个规则由限制100点增加到65535点。

3修复的缺陷

·[279326]关系库转储原始值到SQLServer窄表不成功。

·[278065]关系库转储服务退出写配置有时不完全。

·[273987]关系库转储：报警点的结束时间有的未存储到数据库中。

·[273383]modbus采集：设备忙碌没有应答时，事务号会发生错乱导致不能采集。

·[273646]modbus采集：采集两个点名时出现了设备丢包。

·[279660]报警关联源点为digital类型不能触发。

·[276508]统计点监测点名字与tag名一样,导致无法从界面删除。

·[279470]所有模块的选点界面，选择统计点、计算点、报警点等，列表中的描述均不正确。

·[279659]ODBC接口查询条件合并的判断只比了值,没有比较tag点和运算符。

·[279661]数据源添加时Tag采集属性配置浏览远程OPC失败。

·[276509]一个采集端先配置一个modbus采集器，再配置一个opc采集器，启动两个采集器，opc采集器不能启动，提示读取配置文件错误。

·[273866]关系库采集不能使用宽表。

·[279662]关系库采集name字段长度限制错误导致不能进行表映射。

·[273857]关系库采集time字段不支持datetime类型。

·[279602]备份和恢复:新建一个备份恢复时，若选择已经存在备份文件的路径，则不让创建，该处理不妥。

·[266827]OPC采集器配置工具：OPCServer导出点时,增加前缀后缀的Tag名合法性未校验。

·[274028]内核：配置序列缓存大于2G（4095M），内核当一个序列缓存存满后会flush失败。

·[284372]modbus采集器在winXP系统下只采集一条数据.

·[282802]【采集器】开启buffer时，修改了服务端所在的ip，采集器无法将新的数据传送到服务端.

·[284907]当扫描时发现设备连接断开时，进行了重连，但没有重新执行该次扫描导致第一个组的数据不能采集.

4已知问题与限制

ID | 描述 | 等级 | 规避措施
266919 | 组态：faq:建议iCV组态支持iHD的Tag名的合法特殊字符 -:.()[]+=%@# | 4 | 需要组态显示的ihd数据点,需要符合icv点名称规则
266358 | 计算点极大值过滤，时间间隔为0、非整数，负数，输入有些数据，框架没有校验（阈值也是） | 3 | 计算表达式输入界面不做复杂限制，配置时需注意，如果计算点未正确计算请先检查配置
266918 | 安装：hdSetup建议一键安装，可以在分布列出的每个模块后面增加安装按钮，避免误解 | 4 | 安装过程如果重启计算机，建议重启后运行hdSetup确认是否安装成功
260850 | opc采集超时更新问题：设备和服务器时间不一致，时间戳选择设备，状态点显示为一条超时一条活动 | 4 | 调整设备或DCS时间与服务器时间一致
273231 | Zt组态—饼图、柱状图：建议刷新周期不允许为0、负数和空 | 4 | 界面不做限制，配置时需注意
273229 | Zt组态—饼图、柱状图：组态编辑态中，时间配置为2015-2-29日也可以保存 | 3 | 界面不做限制，配置时需注意
247893 | 权限：Tag修改者，Tag创建者都为admin | 3 | 显示的用户总是admin,与创建的不一致，但不影响权限验证
266795 | 分发：配置分发不支持域名 | 3 | 组态配置分发需要配置实际IP地址
259143 | Odbcsql界面查看，增删数据源或修改数据源名称后，odbcsql里的数据源名称不会自动刷新 | 4 | 修改系统ODBC配置后需重新打开SQL查询窗口进行查询
254180 | Excel中使用历史查询，更改excel中单元格属性，会导致已查询到的数据更改显示为“不合法的起始时间” | 4 | 单元格属性不能随意修改格式，用户手册中说明
256991 | SPC: 建议与SPC报警点关联的普通点不能删除 | 4 | 删除关联普通点后可以手工添加新的
252830 | 使用ESC键，打开的当前iHD程序窗口会退出 | 4 | 操作习惯问题
253898 | 计算：if(0) then('Tag1') else('Tag2')非执行语句中，时间戳和数据质量处理方式不一致 | 4 | 未过滤不执行语句的记录，不影响实际计算结果
248020 | 安装：在安装完成界面，勾选“启动服务（立即重启计算机）”灰化 | 4 | 已经灰化，勾选不影响实际效果
247907 | 报警导出：建议硬盘快满，导出不完整时有提示 | 4 | 可导出到硬盘空间够的硬盘
250146 | Excel插值：函数参数，TagName框中输入Tag名后，Tag名未自动加双引号。 | 4 | 某些字符串不会自动加""，是excel自动做的，插件无法修改.一般使用单元格选择tag名不会遇到这个问题.
249512 | 组态有时运行态不能F7退出 | 4 | 检查ZtDesign或Ztrun是否未正常退出，手工杀掉进程。
222926 | 宽表转储：小数点位数被截断 | 4 | 支持脚本转储，用户通过自定义实现
223737 | 记录：浮点型（float32，float64）上传超范围值，框架中显示为inf，excel中显示的数值也不正确。建议超范围值截断或不能上传。 | 4 | 极限情况，一般工控数据不会超过float64的量程。此种情况一般是传感器故障，应该检查硬件。
223791 | excel中tag下载-tag查询-高级查询，用记录取值范围进行等于查询，记录取值范围=2147483904，查询为空 | 4 | 取值范围溢出，后续考虑在前台加校验进行规避
223795 | 在历史存储记录界面（时间区间模式），按ctrl+/进入修改状态，修改数组函数的Tag名（从有2条记录的Tag1改为只有1条记录的Tag2），并完成修改，显示两条一样的记录，不是有一条显示N/A | 4 | 不影响使用。如果有一样的记录，后续记录忽略。
225236 | 在Excel中，设置判断条件为LT(-1.1E-10)，且对应源Tag为数值型(浮点型：float32,float64)，设置值为-0.00000000012，没有进行报警 | 4 | 长度过长的被截断，不影响正常报警
285835 | 【系统管理工具】-【查询】：建议高级查询时，除普通点之外的点都弹出“不支持高级查询”提示框 | 4 | 提示信息问题,暂不支持高级查询报警点

5升级说明

5.1升级范围

组件（或节点） | 必须升级 | 推荐升级 | 不需要升级 | 其他影响
内核/服务端 | ? |  |  |
客户端 | ? |  |  |
采集器端 | ? |  |  | 2.2.0以前版本如果安装过hdOpcInt采集器服务，需先手工sc delete hdopcint删除，用新的采集器配置工具来配置和安装服务，保存配置后重新启动采集器。
资源管理服务（Tag变量分组） | ? |  |  |

5.2升级方法

1?从2.0.0以及更高版本升级

直接在对应机器上运行安装程序文件，选择升级安装。

注意：

1）iCVBS Server使用iHD插件需要重新上传web升级包。

2）采集器配置的OPC设备需重新选择配置机器名。


P1

Navigation: 2.4.5 >

P1

 Return to chapter overview

前言

宝信实时数据库-iHyperDB是宝信软件研发的一套具有自主知识产权的实时历史数据库系统，它融合宝信多年工控领域研发及工程实践经验，具备高性能、高可靠性、高容量、跨平台、可扩展等特点，在工控领域发挥着连接生产控制系统与信息管理系统的桥梁作用。

本版本发布说明将介绍2.4.5P1补丁版本。

1增强或变化的功能特性

?大数据采集器接口更新ieee1888接口，对应服务端为xinsight1.0.8版本。

?Windows64位SDK，包含Java和C++接口。

2修复的缺陷

Øwin64位客户端excel错误码不能查询

Øwindows进程列表中文导致节点服务管理工具查询进程状态失败

ØOPC采集器ifix冗余运行为服务方式，获取冗余状态不正确

Ømodbus采集器在设备断开后有时候会发送成功但是接收失败的问题

Øexcel插值查询解决部分tag点出现查询失败导致时间戳赋值不当

Ø[288579]excel插值函数说明文字,hd_IntValSpaced，其中SpaceTime注释中1D, 1H, 1M，实际是1d, 1h, 1m；大小写区分

Ø[290896]【客户端历史记录导出】-导出文件名后缀为.cvs)

Ø[291725]使用excel导入系统点，其中包括2个modbus采集器的系统点;批量添加普通点,其中部分tag点的采集器配置不正确导致id不连续

Ø[291884]安装补丁-开着excel安装补丁，安装程序卡住不动

Ø[291933]组态画面中数据A_Quality显示为数值

Ø[291944]英文版，从关系数据库宽表采集，添加点后提示“no value matched”

3已知问题与限制

ID | 描述 | 等级 | 规避措施
264320 | 权限：本机登录，仍需输入用户名及密码, 导致统计点无法统计 | 3 | 重启网络服务.。因为权限模块启动时插入本地信任到kernel.db和hdkernel偶尔有冲突，统一到V3版本，同一配置服务来操作kernel.db来解决。
266770 | 统计点：建点时遇到连接超时，前台框架没法重新建该点，报该点已存在，但实际查不到该点 | 3 | 修改名称或者从kernel.db删除。因为新建统计点并不是个原子操作，从概率上存在已创建普通点但创建统计属性失败情况，统一到V3版本解决。
291985 | 【RDBcollector】 -英文版，无法从sqlserver采集宽表数据 | 3 | P2补丁修复
291991 | 【excel】 -历史插值记录，选择string和blob点会异常 | 3 | 选择数值类型可正常插值
261468 | 安装：卸载, 自定义路径下的文件夹未被删除 | 3 | 如果确认不需要数据，可以手工删除自定义的非安装目录下的Data文件夹。
279858 | 配置点每次新增加一个tag点，都需要选择服务器 | 4 | 只配置一个服务器时可以记住上次选择的,多个服务器时需要手动切换。
279678 | 【转储】-不同周期的点配置在同一张宽表中，周期慢的点会漏 | 4 | 相同采样周期的配置在一张宽表。
279846 | 【英文版】【dispatch】分发失败错误乱码 | 4 | 个别中文提示乱码,可以根据错误码数值查询得知具体错误信息。
279853 | 【iHD2iHD】：删除采集器后，目标服务器中的系统状态点未一同删除 | 4 | 多余状态点，不影响采集功能。
280512 | iHD2iHD采集：未选中采集器，点击源点后的【选择】按钮，可以点击，但弹出界面或提示信息 | 4 | 提示信息，正常操作不影响配置功能。
280520 | iHD2iHD采集：采集器状态信息不详细 | 4 | 不影响采集功能。

4升级说明

4.1升级范围

组件（或节点） | 必须升级 | 推荐升级 | 不需要升级 | 其他影响
服务端 | ? |  |  |
客户端 | ? |  |  |
采集器端 | ? |  |  |

4.2升级方法

在安装2.4.5版本的系统上运行2.4.5P1补丁安装程序。

注意：

1￡补丁版本有win32/64，中英文区别，安装时请使用对应的版本；

2￡升级前需要退出iHD相关程序，包括iHD服务和客户端，以及使用iHD接口的应用程序，如安装插件的excle和iCV组态等。


3.0.2

3.0.2

1新增功能特性

1.1支持分布式节点

·服务器可横向扩展，整个系统支持点数可达三千万。系统包含一个配置中心以及若干数据节点和客户端。API层面解决透明访问，用户只需要知道配置中心IP，客户端所有操作直接调用API接口，不需要指定发送到哪个服务器，配置中心在配置时自动实现负载均衡。

·

1.2数据节点服务端支持双机冗余

·分布式实时数据库的数据结点的双机冗余功能，保证用户的配置、数据不丢失，系统可持续运行。主备机间的冗余切换在数秒之内完成，配置信息、数据实现自动同步。配置不在数据节点主备机间同步，主备机直接从配置中心同步配置。

1.3统计点新增计算周期和量程清零功能

1.4工具

·提供分布式数据节点监控工具

1.5接口

·提供分布式API，SDK支持C++/C#/Java/Python等编程语言。

1.6xinsight大数据平台采集器

可将实时数据库所有普通点数据转发到xinsight大数据平台。

1.7iMV数据转发代理

可将实时数据库数据转发到iMV平台,在移动端和浏览器等展示数据。

1.8关系数据库转储和采集的时间字段增加支持datetime和timestamp

具体不同数据库对应支持类型参考用户手册。

2增强或变化的功能特性

·服务端(分布式服务器对外的配置中心)端口默认为5673。

·C++API改为hdKingAPI接口，使用VC2010编译, C#sdk改为使用.Net Framework4.0。

·界面优化调整

报警客户端历史记录查询的勾选支持“全选”，列选项和界面布局在客户端重启时可以恢复。

3已知问题与限制

ID | 描述 | 等级 | 规避措施
288428 | 分发配置-组态画面没有刷新按钮，当两个人同时在签出时，看不到画面的签出或签入的状态 | 4 | 需重启客户端,后续优化在线配置
288677 | 建议大数据采集器有卸载功能 | 4 | 直接删除原来的安装目录
288419 | [组态]-报警控件在添加和删除报警点后,没有刷新 | 4 | 需重启客户端,后续优化在线配置
283620 | hdexport.db文件不一定会按照周期写，而是要等待一批转储事务完毕的空闲才会写 | 4 | 不影响转储功能,等转储服务正常退出可以保存最新已转储的时间戳.
283704 | 卸载ihdOPCServer时误删除系统opc库会导致后面安装客户端浏览OPCServer时出错, 报112269 创建COM实例失败 | 4 | 再安装opcserver,注意卸载时不要删除opc系统库,用户手册FAQ增加说明.
287797 | 采集器配置工具界面-modbus/OPC扫描组：相位--建议提示合法范围 | 4 | 错误提示不影响正常配置.
276909 | [SPC报警点]-创建时，新建的关联点没办法初始值,必须先写值后才能触发spc报警 | 4 | 暂不支持，必需应用来写初始值.
276862 | 【计算点】-建议配置时不让关联不支持的点，如报警点等 | 4 | 界面暂不校验，需配置时注意选择.
276994 | 先安装数据节点和客户端后，再安装配置中心，没办法完成 | 4 | 用户手册说明，一个机器要装配置中心，必须先装好才能装其他.

4升级说明

1?从2.4.5以及更高版本升级

支持服务端升级，升级前有一些准备工作：

1）停止原2.4.5的服务，备份服务端安装目录下面的配置config文件夹和数据Data文件夹；

2）全新安装3.0版本配置中心服务端，先不要启动服务。

然后，通过安装目录下的hdUpdateConfig.exe和hdUpdateDataTool.exe升级tag配置和数据。

具体参见用户手册操作说明。

2?2.4.5以前版本请先升级到2.4.5。


3.1.0

3.1.0

1新增功能特性

1.1支持分布式节点

服务器可横向扩展，整个系统支持点数可达三千万。

系统包含一个配置中心以及若干数据节点和客户端。API层面解决透明访问，用户只需要知道配置中心IP，客户端所有操作直接调用API接口，不需要指定发送到哪个服务器，配置中心在配置时自动实现负载均衡。

1.2数据节点服务端支持双机冗余

分布式实时数据库的数据结点的双机冗余功能，保证用户的配置、数据不丢失，系统可持续运行。主备机间的冗余切换在数秒之内完成，配置信息、数据实现自动同步。配置不在数据节点主备机间同步，主备机直接从配置中心同步配置。

1.3统计点新增计算周期和量程清零功能

1.4计算点新增支持通知模式；内置函数增加NoOutput,BadVal,TagUnixsec,PrevVal,PrevUnixsec,PrevMs,PrevBadVal,提供内置函数选择功能

1.5工具

提供分布式数据节点监控工具

1.6接口

提供分布式API，SDK支持C++/C#/Java/Python等编程语言。

1.7xinsight大数据平台采集器

可将实时数据库所有普通点数据转发到xinsight大数据平台。

1.8iMV数据转发代理

可将实时数据库数据转发到iMV平台,在移动端和浏览器等展示数据和报警。

1.9增加win64位SDK

安装包iHyperDB3_SDK_x64.exe，使用帮助参见iHDSDKdoc.chm。增加sn3_register_callback回调接口。

1.10关系数据库转储和采集的时间字段增加支持datetime和timestamp

具体不同数据库对应支持类型参考用户手册。

2增强或变化的功能特性

服务端(分布式服务器对外的配置中心)端口默认为5673。

C++API改为hdKingAPI接口，使用VC2010编译, C#sdk改为使用.Net Framework4.0。

界面优化调整

系统管理工具分发配置一级子菜单更名为“组态”，节点管理去掉web节点类型，组态管理增加刷新按钮；iMV代理配置统一到系统管理工具界面。

报警客户端历史记录查询的勾选支持“全选”，列选项和界面布局在客户端重启时可以恢复。

Buffer.xml文件名修改为HD3Buffer.xml。

关系库转储和采集器配置文件以tag名称为准，不依赖id配置。

3已知问题与限制

ID | 描述 | 等级 | 规避措施
289377 | [Excel上传]32位中文版，上传计算点时报错是英文提示 | 4 | 提示信息，不影响配置
291208 | 【组态】数据质量为I/O Timeout，但是组态显示为good | 4 | A_Quality字符串不正确，使用F_Quailty字段判断质量即可
290746 | 【IMV】加载功能模块失败（配置中心是64的）imv接口win64未发布 | 4 | 待新的iMV发布后增加win64位支持
288428 | 分发配置-组态画面没有刷新按钮，当两个人同时在签出时，看不到画面的签出或签入的状态 | 4 | 需重启客户端,后续优化在线配置
288677 | 建议大数据采集器有卸载功能 | 4 | 直接删除原来的安装目录
288419 | [组态]-报警控件在添加和删除报警点后,没有刷新 | 4 | 需重启客户端,后续优化在线配置
283620 | hdexport.db文件不一定会按照周期写，而是要等待一批转储事务完毕的空闲才会写 | 4 | 不影响转储功能,等转储服务正常退出可以保存最新已转储的时间戳.
283704 | 卸载ihdOPCServer时误删除系统opc库会导致后面安装客户端浏览OPCServer时出错, 报112269 创建COM实例失败 | 4 | 再安装opcserver,注意卸载时不要删除opc系统库,用户手册FAQ增加说明.
287797 | 采集器配置工具界面-modbus/OPC扫描组：相位--建议提示合法范围 | 4 | 错误提示不影响正常配置.
276909 | [SPC报警点]-创建时，新建的关联点没办法初始值,必须先写值后才能触发spc报警 | 4 | 暂不支持，必需应用来写初始值.
276862 | 【计算点】-建议配置时不让关联不支持的点，如报警点等 | 4 | 界面暂不校验，需配置时注意选择.
276994 | 先安装数据节点和客户端后，再安装配置中心，没办法完成 | 4 | 用户手册说明，一个机器要装配置中心，必须先装好才能装其他.

4升级说明

1?从2.4.5以及更高版本升级

支持服务端升级，升级前有一些准备工作：

1）停止原2.4.5的服务，备份服务端安装目录下面的配置config文件夹和数据Data文件夹；

2）全新安装3.0版本配置中心服务端，先不要启动服务。

然后，通过安装目录下的hdUpdateConfig.exe和hdUpdateDataTool.exe升级tag配置和数据。

具体参见用户手册操作说明。

2?2.4.5以前版本请先升级到2.4.5。


3.1.1

3.1.1

新增功能

Øwin64位增加支持组态和iMV数据代理转发功能

Ø服务端支持solaris 11.2/linux redhat7

增强或变化的功能特性

Ø组态更新icv5.6.1；

ØC#SDK增加多点接口；

ØBuffer缓存增大,提升性能. NOTE:缓存文件格式变化；

Ø统计服务性能优化:统计计算过程中如果要添加统计点，优先添加统计点，统计计算先暂停，防止统计计算历史时间太长导致客户端超时。

修复的缺陷

Ø[293894][备份配置]自动备份，配置源服务器IP，保存成功，但是实际没有修改xml文件，仍然是127.0.0.1；

Ø备份服务安装服务后不能启动；

Ø[293827]关系库采集器状态点添加不正确,配置从关系数据库采集窄表，保存提示“注册关系数据库采集器相关操作失败。错误码是7”；

Ø[291208]【组态】数据质量为I/O Timeout，但是组态显示为good；

Ø[291739]【组态】[偶发]ZT运行异常；

Ø[290746]【IMV】加载功能模块失败（配置中心是64的）imv接口win64未发布；

Ø[276996]采集器：win64位版本，opc采集器和modbus采集器都启动不了。


3.2.1

3.2.1

1新增功能特性

1.1支持分布式节点

服务器可横向扩展，整个系统支持点数可达三千万。

系统包含一个配置中心以及若干数据节点和客户端。API层面解决透明访问，用户只需要知道配置中心IP，客户端所有操作直接调用API接口，不需要指定发送到哪个服务器，配置中心在配置时自动实现负载均衡。

1.2数据节点服务端支持双机冗余

分布式实时数据库的数据结点的双机冗余功能，保证用户的配置、数据不丢失，系统可持续运行。主备机间的冗余切换在数秒之内完成，配置信息、数据实现自动同步。配置不在数据节点主备机间同步，主备机直接从配置中心同步配置。

1.3配置中心服务端支持双机冗余

分布式实时数据库的配置中心支持双机冗余，配置中心和数据节点可部署一起，可以实现最少2台机器的热备，防止服务器故障导致数据丢失。具体参加帮助手册。

开始使用 > 安装和卸载iHyperDB > 如何部署热备

1.4服务端支持双网卡配置

对于双网卡配置的服务器，增加双IP配置，可以让管理网和现场采集层都可以访问实时数据库。

添加数据节点时也设置双IP。

1.5统计点新增计算周期和量程清零功能

1.6计算点新增支持通知模式；内置函数增加NoOutput,BadVal,TagUnixsec,PrevVal,PrevUnixsec,PrevMs,PrevBadVal,提供内置函数选择功能

1.7xinsight大数据平台采集器

可将实时数据库所有普通点数据转发到xinsight大数据平台。

1.8iMV数据转发代理

可将实时数据库数据转发到iMV平台,在移动端和浏览器等展示数据和报警。

1.9关系数据库转储和采集的时间字段增加支持datetime和timestamp

具体不同数据库对应支持类型参考用户手册。

1.10工具

提供分布式数据节点监控工具

1.11接口

Ø提供分布式API，SDK支持C++/C#/Java/Python等编程语言。

Ø增加win64位SDK

安装包iHyperDB3_SDK_x64.exe，使用帮助参见iHDSDKdoc.chm。增加sn3_register_callback回调接口。

2增强或变化的功能特性

Ø服务端(分布式服务器对外的配置中心)端口默认为5673。

ØC++API改为hdKingAPI接口，使用VC2010(+SP1)编译, C#sdk改为使用.Net Framework4.0。

Ø界面优化调整

系统管理工具分发配置一级子菜单更名为“组态”，节点管理去掉web节点类型，组态管理增加刷新按钮；iMV代理配置统一到系统管理工具界面。

报警客户端历史记录查询的勾选支持“全选”，列选项和界面布局在客户端重启时可以恢复。

ØBuffer缓存增大,提升性能。Buffer.xml文件名修改为HD3Buffer.xml。（缓存文件格式不同于v2.4）

Ø关系库转储和采集器的配置文件以tag名称为准，不依赖id配置。

3已知问题与限制

ID | 描述 | 等级 | 规避措施
297739 | OEM 客户端安装，32位版本组态不能选择 | 3 | 需要32组态的单独制作安装包
289377 | [Excel上传]32位中文版，上传计算点时报错是英文提示 | 4 | 提示信息，不影响配置
288428 | 分发配置-组态画面没有刷新按钮，当两个人同时在签出时，看不到画面的签出或签入的状态 | 4 | 需重启客户端,后续优化在线配置
288677 | 建议大数据采集器有卸载功能 | 4 | 直接删除原来的安装目录
288419 | [组态]-报警控件在添加和删除报警点后,没有刷新 | 4 | 需重启客户端,后续优化在线配置
287797 | 采集器配置工具界面-modbus/OPC扫描组：相位--建议提示合法范围 | 4 | 错误提示不影响正常配置.
276909 | [SPC报警点]-创建时，新建的关联点没办法初始值,必须先写值后才能触发spc报警 | 4 | 暂不支持，必需应用来写初始值.
276862 | 【计算点】-建议配置时不让关联不支持的点，如报警点等 | 4 | 界面暂不校验，需配置时注意选择.
276994 | 先安装数据节点和客户端后，再安装配置中心，没办法完成 | 4 | 用户手册说明，一个机器要装配置中心，必须先装好才能装其他.
298218 | iHD2iHD转储一段时间后，iHDCollector停止服务。 | 4 | 下一版本重构该采集器
298259 | 【Bigdata】-32位升级安装，导致大数据采集配置文件信息丢失 | 3 | 大数据采集器配置文件需重新修改配置

4升级说明

Ø从2.4.5升级

支持服务端升级，升级前有一些准备工作：

1）停止原2.4.5的服务，备份服务端安装目录下面的配置config文件夹和数据Data文件夹；

2）全新安装3.0版本配置中心服务端，先不要启动服务。

然后，通过安装目录下的hdUpdateConfig.exe和hdUpdateDataTool.exe升级tag配置和数据。

具体参见用户手册操作说明。

客户端和采集器需自己备份后再全新安装新版本。

Ø2.4.5以前版本请先升级到2.4.5。

Ø3.1.0版本，直接覆盖安装，注意采集器缓存文件不兼容，需停止buffer后删除原缓存文件再重启。

Ø3.1.1以后版本，直接覆盖安装，如果需要修改原来部署的单机切换双机热备,参考用户文档升级说明。


3.3.0

3.3.0

1新增功能特性

1.1配置中心冗余状态显示、

1.2主备状态引入第三方仲裁机制

安装主备冗余配置网络检测IP，数据节点的冗余服务会自动检测与能否ping通网络检测IP，能ping通的机器为主机，不能ping通的机器为备机。网络检测IP可以是网关，也可以是网络上一个第三方服务器IP。

1.3增加配置中心IP修改后下发到数据节点的功能

由于网络环境的变化，机器IP发生改变，可参考用户手册：

常见问题 > IP地址发生变化时如何修改.

1.4客户端统计功能增加支持函数

excel函数中包含数据统计函数（包括最大值、最小值、算术平均值、加权时间平均值、求和、积分、差值），以及计数函数，计时函数。

可参考用户手册：

功能明细 > 数据展示 > 电子表格 > excel客户端统计

1.5注册值变化时数据回调通知接口

接口名为sn3_register_value_change_callback和sn3_unregister_value_change_callback; 具体用法和示例代码见SDK用户手册。

1.6增加大数据采集器参数配置界面

可通过数据节点服务管理工具设置大数据采集器连接参数。

2增强或变化的功能特性

Ø过滤旧的乱序数据，默认乱序接口过滤掉比最新快照记录时间戳早一个星期的数据.

ØJAVASDK接口优化修改，对于部分成功的批量操作可返回子错误码. 注意部分接口参数修改,须修改二次开发程序.

ØC#SDK支持Blob类型数据，合并stringblob接口和data查询接口.

Ø组态节点管理中，实时数据库服务器修改为只允许添加1个。

3修复的缺陷

Ø298255【组态】DZTPLAY3在编辑态缩放后显示不全

Ø298259【Bigdata】-32位升级安装，导致大数据采集配置文件信息丢失

Ø298702 Excel配置tag点的权限所属组不正确

Ø298264 在没有关闭采集器进程的情况下，关闭buffer，并保存，会导致采集器管理工具崩溃

ØiMV代理备机也发送数据

Ø关系库采集的执行周期多乘了1000倍

Ø关系库采集器状态更新不正确

Ø关系数据库转储在一个规则SQL执行异常的情况下导致其它规则也不转储

Ø冗余服务停止很慢导致下次启动失败

Øjavasdk 存储blob数据不正确

4已知问题与限制

ID | 描述 | 等级 | 规避措施
302054 | 卸载时，保留配置和数据，再次安装时需要从新安装postgreSQL。 | 4 | 根据原配置单独安装postgreSQL,
302055 | 卸载时，保留配置和数据，再次安装时默认勾选为本机安装数据节点。 | 4 | 默认不勾选，如果误勾选也不影响继续安装.
302065 | 关系数据库转储时，连接不上数据库时，提示信息为英文。 | 4 | 关系库返回的配置错误提示，正确配置不影响.
302053 | 系统管理平台登录超时时，错误码为英文 | 4 | 错误提示，不影响正确配置.

5升级说明

1.3.2.1之前版本，先升级到3.2.1。2.4.5备份并升级至3.2.0案例，详情请点击在线用户手册链接：典型案例 > 典型案例13-iHD2.4.5备份恢复升级；

2.3.2.1以后版本，直接覆盖安装，如果需要修改原来部署的单机切换双机热备,参考用户文档说明。


3.3.0 P1

Navigation: 3.3.0 >

3.3.0 P1

 Return to chapter overview

1修复的缺陷

?Kernel缓存切换后有时启动异常

?ODBC配置单机版时SQL查询失败

?转储服务不能转发oracle数据库

2已知问题与限制

ID | 描述 | 等级 | 规避措施
302054 | 卸载时，保留配置和数据，再次安装时需要从新安装postgreSQL。 | 4 | 根据原配置单独安装postgreSQL,
302055 | 卸载时，保留配置和数据，再次安装时默认勾选为本机安装数据节点。 | 4 | 默认不勾选，如果误勾选也不影响继续安装.
302065 | 关系数据库转储时，连接不上数据库时，提示信息为英文。 | 4 | 关系库返回的配置错误提示，正确配置不影响.
302053 | 系统管理平台登录超时时，错误码为英文 | 4 | 错误提示，不影响正确配置.
302301 | 【主备冗余】--主备切换，备机当不了配置中心的主机 | 4 | 主机启动后,备机从活动切换为非活动,主机为活动状态,不影响客户端操作.

3升级说明

3.1 升级范围

组件（或节点） | 必须升级 | 推荐升级 | 不需要升级 | 其他影响
配置中心服务端 |  | ? |  |
数据节点服务端 | ? |  |  |
客户端 | ? |  |  |

3.2 升级方法

在安装3.3.0版本的系统上运行P1补丁安装程序。

注意：

1)补丁版本有win32/64，中英文区别，安装时请使用对应的版本；

2)升级前需要退出iHD相关程序，包括iHD服务和客户端，以及使用iHD接口的应用程序，如安装插件的excle和iCV组态等。


3.5.0

3.5.0

1.新增功能特性

1)支持一机双网冗余

配置并部署单机双网冗余模式，客户端访问服务器可同时连接服务器的2个网卡地址，即实现双网冗余的功能。具体配置参见iHyperDB用户手册： 开始使用 > 安装和卸载 > 部署单机双网冗余

2)关系库转储配置支持excel文件导入导出

3)关系库采集配置支持excel文件导入导出

4)iMV代理支持读取点的描述

在CVS界面通过在点名后面使用A_DESC域名来读取.

5)支持webservice接口

SDK安装包提供webservice接口war包，具体使用参考SDK用户手册。

2增强或变化的功能特性

v关系库采集器配置去掉表别名，直接使用表名。

v大数据采集器优化,支持多线程发送数据。

v内核性能优化，读写消息独立线程处理。

3修复的缺陷

v303443【kernel】--同步尚未结束的时候将kernel服务停掉重启，kernel起不来

v282803开启buffer时,修改了服务端所在的ip，采集器无法将新的数据传送到服务端

v自动断开无数据交互的连接在非windows系统死锁.

vwindows集群部署时同步配置失败

v配置中心主机停止后再启动，备机冗余状态从活动切换为非活动

viMV代理单机版不能转发报警

viMV代理启动获取数据慢

vservercfg.xml升级时版本号没有修改

v301741【组态】-文本控件有时无法关联tag点

v303973【转储到关系数据库】 开始转储的时候，断开数据库的网络，然后过段时间再恢复数据库的网络，MySQL和DB2没有转储。

4已知问题与限制

ID | 级别 | 缺陷说明 | 规避措施
302054 | 4 | 卸载时，保留配置和数据，再次安装时需要从新安装postgreSQL。 | 根据原配置单独安装postgreSQL
302055 | 4 | 卸载时，保留配置和数据，再次安装时默认勾选为本机安装数据节点。 | 默认不勾选，如果误勾选也不影响继续安装。
301629 | 3 | postgreSQL有时异常退出 | 偶发，可部署双机冗余，避免单节点故障，发现停止后需手工重启postgreSQL，后续版本使用内存数据库sqlite替代。
304688 | 3 | 【imv】配置错误时imv代理崩溃 | 正确配置没影响,只是租户配置不正确时代理框架有时异常,后续不使用代理框架方案。

5升级说明

1)3.2.1之前版本，先升级到3.2.1。2.4.5备份并升级至3.2.0案例，详情请点击在线用户手册链接：典型案例 > 典型案例13-iHD2.4.5备份恢复升级；

2)3.2.1以后版本，直接覆盖安装，如果需要修改原来部署的单机切换双机热备,参考用户文档说明。


3.6.0

3.6.0

1.新增功能特性

v支持WPS表格插件(32位WPS2016)；

v关系库转储和采集支持postgresql；

v关系库转储时间字段支持timestamp字段；

v计算表达式支持自身点名，添加函数NoneRecord判断是否无记录状态；

v大数据采集器支持计算点和统计点。

2.增强或变化的功能特性

v配置中心postgresql数据库改为sqlite文件，v3.5.0以上版本可自动升级安装，之前版本先升级到v3.5.0

vCVS服务新接口框架，不用在ihd配置iMV代理，支持CVS版本为3.0.0

vJavaSDK支持版本为1.7/1.8

v转储到关系库配置支持多个规则印射到同一个表

vtag点采集属性中设备点名长度由64改为256. 注意：二次开发必须全部升级。包括头文件和库。

v关系库转储配置导出excel文件的rule和tag页都增加tablealiasname一列,老版本导入时需手工增加。

3.修复的缺陷

v[305700]icv转储到ihd的buffer中缓存的点的类型和ihd中相应的id的点的类型不一致，导致转储到ihd后，ihd的kernel异常。

v[306166]C++SDK:注册时间戳变化回调函数可能死锁。

v[306258]删除统计点可能导致统计服务异常。

4.已知问题与限制

ID | 级别 | 缺陷说明 | 规避措施
306813 | 4 | 【Install】-ihd客户端postgresql转储和采集需要依赖VC2013库，建议在安装服务端和客户端的时候，自动安装所依赖的VC库 | 参考用户手册配置手工配置转储环境
306740 | 3 | 自动备份和还原功能不全 | 参考用户手册手工备份配置库ConfigCenter.db
305635 | 3 | 【icv转储】-icv-Redhat，转储到ihd，cv的点中含有中文描述或是中文字符串，转储后报字符集编码错误，导致其他的icv转储到ihd异常 | 升级Redhat系统地ihd到3.6版本
288419 | 4 | [组态]-报警控件在添加和删除报警点后,没有刷新 | 不支持自动更新，需重开报警控件画面注册点后刷新

5.升级说明

1)3.2.1之前版本，先升级到3.2.1。2.4.5备份并升级至3.2.0案例，详情请点击在线用户手册链接：典型案例 > 典型案例13-iHD2.4.5备份恢复升级；

2)3.2.1～3.3.0版本，先升级到3.5.0。如果需要修改原来部署的单机切换双机热备,参考用户文档说明。

3)3.5.0版本，直接覆盖安装。


3.6.1

3.6.1

3.6.1版本相对于3.6.0版本主要增加支持PythonSDK和OLEDB接口，增强转储脚本和统计点等功能，具体请参考下文。

1.新增功能特性

vPythonSDK,支持python2.7

vOLE DB接口，可在组态脚本中直接使用SQL语句查询历史数据

v转储脚本支持自定义python脚本，提供定时调用功能

v支持cvs实时报警分组功能. cvs版本为3.2.0以上

2.增强或变化的功能特性

v统计点增加采样是否使用Bad记录的属性，相应配置和接口增加属性。

vJavaSDK增加统计点和计算点管理接口。各种类型点的删除接口统一为一个。

vC#SDK增加统计点和计算点管理接口。

vExcel和WPS插件菜单调整，数据查询和管理功能布局分组。

vmodbus采集支持linux系统。

3.修复的缺陷

v[310381]icv乱序转储到ihd，选择压缩可能导致iHD 中出现重复记录

v[310280]插入乱序数据,归档数据索引文件可能错乱!

v[311048]归档切换文件时退出后无法启动,报错110204

v[307961]在配置内外网的时候，超过24个字符串，会导致配置中心读取配置失败

v[306740]备份功能不能自动备份配置中心sqlite

v[309389]编辑SPC报警点界面名字为空

v[309425]3.5升级到3.6.0的hdConfigCenter服务无法停止

v[308975][ihd2ihd2采集器]5000点采集，目标服务器快照比源服务器慢几小时

v[309977]Excel修改和查询扩展属性不生效

v[310746]excel表格通过函数来获取值的时候，起止时间设置的不对会导致excel异常退出

vapi注册数据接口缓存满了时如果有string类型点会导致内存泄露。

4.已知问题与限制

ID | 级别 | 缺陷说明 | 规避措施
310669 | 3 | 【关系数据库采集】--添加一个表映射不进行配置，点击保存，采集服务报错。113524 | 修改配置正确后可以正常采集。
310385 | 3 | 【备份系统】--手动备份，停掉服务，状态有时是备份完毕，有时能提示116839。 | 强制退出状态有时不正确,不影响正常备份。
310410 | 4 | 【手动备份】--在手动备份未完成前停止备份，备份装态显示为备份完毕，建议修改。 | 强制退出状态有时不正确,不影响正常备份。
309395 | 4 | 编辑报警点，其数字量集为空。 | 报警点不需要配置数字量集
309943 | 3 | 【BigData】-安装的时候，不勾选大数据采集器，将所有服务安装成系统服务，那么在系统服务管理工具里面仍然可以查看到“大数据采集器”的服务。 | 不使用的功能,不影响其他服务运行。

5.升级说明

1)3.2.1之前版本，先升级到3.2.1；2.4.5备份并升级至3.2.0案例，详情请点击在线用户手册链接：典型案例 > 典型案例13-iHD2.4.5备份恢复升级；

2)3.2.1～3.3.0版本，先升级到3.5.0。如果需要修改原来部署的单机切换双机热备,详情请点击在线用户手册链接：开始使用 > 安装和卸载 > 从单机到双机热备冗余的升级）；

3)3.5.0版本，先升级到3.6.0版本；

4)3.6.0版本直接覆盖安装。


3.6.1 P1

Navigation: 3.6.1 >

3.6.1 P1

 Return to chapter overview

3.6.1 P1补丁版本说明，具体请参考下文。

1.修复的缺陷

v[311637]多层嵌套条件表达式可能导致计算服务异常

v[311758]【大数据采集器】停止大数据采集器30秒后再次启动，在大数据平台历史数据中没有这30秒原始值

v[311757]【大数据采集】--删除一个tag点后，新增一个同名但不同类型的tag点，不能上传数据到大数据平台

v采集器缓存,配置的数据发送超时不生效

v配置中心冗余状态在操作大量配置时可能不正确

v主备冗余时内核收到类型不一致的数据可能出现异常

vnetmgr非活动状态发送回调数据

2.已知问题与限制

ID | 级别 | 缺陷说明 | 规避措施
310669 | 3 | 【关系数据库采集】添加一个表映射不进行配置，点击保存，采集服务报错113524。 | 修改配置正确后可以正常采集
310385 | 3 | 【备份系统】手动备份，停掉服务，状态有时是备份完毕，有时能提示116839。 | 强制退出状态有时不正确,不影响正常备份。
310410 | 4 | 【手动备份】在手动备份未完成前停止备份，备份装态显示为备份完毕，建议修改。 | 强制退出状态有时不正确,不影响正常备份。
309395 | 4 | 编辑报警点，其数字量集为空。 | 报警点不需要配置数字量集
309943 | 3 | 【BigData】安装的时候，不勾选大数据采集器，将所有服务安装成系统服务，那么在系统服务管理工具里面仍然可以查看到“大数据采集器”的服务。 | 不使用的功能,不影响其他服务运行

3.升级说明

v升级范围

组件（或节点） | 必须升级 | 推荐升级 | 不需要升级 | 其他影响
配置中心服务端 | ■ |  |  |
数据节点服务端 | ■ |  |  |
客户端 |  | ■ |  |

v升级方法

在安装3.6.1版本的系统上运行P1补丁安装程序。

注意：

1)补丁版本有win32/64区别，安装时请使用对应的版本；

2)升级前需要退出iHD相关程序，包括iHD服务和客户端，以及使用iHD接口的应用程序，如安装插件的excle和iCV组态等。


3.6.1 P2

Navigation: 3.6.1 >

3.6.1 P2

 Return to chapter overview

3.6.1 P2补丁版本说明，具体请参考下文。

1.修复的缺陷

v【数据转储】关系数据库中导入错误表格，系统管理工具退出，再次进入添加的连接丢失。

v大数据采集器内存泄露

v统计点关联源点名包含中文会导致同步失败不能获取数据

vPythonSDK历史记录查询接口失败

vbuffer启动时等待连接成功再继续接收数据

2.已知问题与限制

ID | 级别 | 缺陷说明 | 规避措施
310669 | 3 | 【关系数据库采集】添加一个表映射不进行配置，点击保存，采集服务报错113524。 | 修改配置正确后可以正常采集。
310821 | 4 | 【用户手册】32位主备——数据恢复时数据节点服务要全启。 | 用户手册补充说明
311247 | 4 | 【用户手册】中关于“组态新建，编辑画面”章节的链接错误。 | 用户手册已完成修改
311224 | 4 | 【用户手册】安装说明中关于“内存缓冲区大小”、“硬盘文件大小“配置描述不够精确。 | 用户手册补充说明
310385 | 3 | 【备份系统】手动备份，停掉服务，状态有时是备份完毕，有时能提示116839。 | 强制退出状态有时不正确,不影响正常备份。
310410 | 4 | 【手动备份】在手动备份未完成前停止备份，备份装态显示为备份完毕，建议修改。 | 强制退出状态有时不正确,不影响正常备份
309395 | 4 | 编辑报警点，其数字量集为空。 | 报警点不需要配置数字量集
309943 | 3 | 【BigData】安装的时候，不勾选大数据采集器，将所有服务安装成系统服务，那么在系统服务管理工具里面仍然可以查看到“大数据采集器”的服务。 | 不使用的功能,不影响其他服务运行
317546 | 4 | iHD2iHD导入：源服务器为主备，目标服务器为2个单机，只有第一次导入提示信息。 | 错误配置提示信息,不影响正常配置功能.

3.升级说明

v升级范围

组件（或节点） | 必须升级 | 推荐升级 | 不需要升级 | 其他影响
配置中心服务端 | ■ |  |  |
数据节点服务端 | ■ |  |  |
客户端 |  | ■ |  |

v升级方法

在安装3.6.1版本的系统上运行补丁安装程序。

注意：

1)补丁版本有win32/64区别，安装时请使用对应的版本；

2)升级前需要退出iHD相关程序，包括iHD服务和客户端，以及使用iHD接口的应用程序，如安装插件的excle和iCV组态等。


3.6.1 P3

Navigation: 3.6.1 >

3.6.1 P3

 Return to chapter overview

3.6.1 P3补丁版本说明，具体请参考下文。

1.新增功能

v支持iPlat平台数据推送，对应iPlat版本0.2.0

2.修复的缺陷

vlinux api日志路径不正确bug

vsn_query_snapshots 查快照接口blob长度校验错误

v采集器连接设备不成功时日志太多bug

3.升级说明

v升级范围

组件（或节点） | 必须升级 | 推荐升级 | 不需要升级 | 其他影响
配置中心服务端 |  |  | ■ |
数据节点服务端 |  |  | ■ |
客户端 |  | ■ |  |

v升级方法

在安装3.6.1版本的系统上运行补丁安装程序。

注意：

1)补丁版本有win32/64区别，安装时请使用对应的版本；

2)升级前需要退出iHD相关程序，包括iHD服务和客户端，以及使用iHD接口的应用程序，如安装插件的excle和iCV组态等。


3.7.5

3.7.5

3.7.5版本相对于3.6.1版本主要增加hdRTD2ihd实时数据转发，PI2IHD实时数据转发，hdOpcUA数据发布等功能，具体请参考下文。

1.新增功能特性

vhdRTD2ihd实时数据转发；

vPI2IHD实时数据转发；

vhdOpcUA数据发布；

v服务管理工具中加入hdRTD2ihd实时数据转发，hdOpcUA的服务启停以及安装卸载。

2.增强或变化的功能特性

v不再支持iMV、xInsight-CVS的web数据展示；（前端采用iMV、xInsight-CVS方案，iHD尽量使用3.6.1以前版本。）

v改为支持iPlat系列产品展示实时和历史数据。

3.修复的缺陷

v关系库采集DB2数据时间戳timestamp解析有时错误；

vHDPubServer查询中文点名乱码；

vHDPubServer中文字符串乱码；

vHDPubServer分包发送，修复发送数据包超限，连接断开问题；

vHDPubServer线程崩溃。

4.升级安装说明

1)3.2.1之前版本，先升级到3.2.1，再升级到3.5.0，再根据下图进行覆盖安装至3.7.5；2.4.5备份并升级至3.2.0案例，详情请点击在线用户手册链接：典型案例 > 典型案例13-iHD2.4.5备份恢复升级；

2)3.2.1～3.3.0版本，先升级到3.5.0，再根据下图进行覆盖安装至3.7.5。如果需要修改原来部署的单机切换双机热备,详情请点击在线用户手册链接：开始使用 > 安装和卸载 > 从单机到双机热备冗余的升级）；

3)3.5.0之前版本，先升级到3.5.0版本，再根据下图进行覆盖安装至3.7.5；

4)3.6.0之后版本，根据下图进行覆盖安装至3.7.5；

5)3.6.1版本覆盖安装3.7.5的注意事项：

注意：3.6.1覆盖安装3.7.5升级后，log.xml文件末尾</logc>上面需要手工添加一段配置信息，如下：

<appender name="hdopcuaFile" type="rollingfile" logdir="C:/iHyperDB/Log/" prefix="hdopcua" rollingpolicy="sizerolling" layout="basic" />

<appender name="hdopcuaConsole" type="console" layout="basic" />

<category name="iHyperDB.hdopcua">

<output appender="hdopcuaFile" priority="debug" />

<output appender="hdopcuaConsole" priority="debug" />

</category>


3.7.5_patch

Navigation: 3.7.5 >

3.7.5_patch

 Return to chapter overview

P7

增加功能:

v64位OPCServer安装程序

修复缺陷：

v修复HDPubServer回放接口异常问题

v修复HDPubServer查询ihd状态接口内存泄露

v修复上云服务单点多值发送频率不正确问题

v修复windows网络服务有的客户端连接不成功问题

P6

增加功能:

v支持按照传输数据格式发送不同topic，协议修改为EiInfo格式

P5

增加功能:

v转储关系库支持gbase数据库

修复缺陷：

v修复HDPubServer回放接口字符串类型处理bug

P4

增加功能:

vHDPubserver ihd信息获取接口增加配置中心，冗余以及上云统计信息

修复缺陷:

v修复大数据采集器连接失败时的句柄泄露

P3:

修复缺陷:

v修改admin用户默认密码后HDPubserver不能查询数据

vihd服务端口配置超过32767异常

v服务socketid上限太小导致客户端连接不上

P2:

修复缺陷:

vHDPubserver查询超过65535历史记录时服务异常

vapi统计时间加权平均计算不正确

P1:

增加功能:

vihd数据转发到大数据实时计算平台功能增加上云服务和对应配置工具

vHDPubserver增加iplat-op调用链追踪信息，查询ihd节点状态，批量查询插值增加不同条件查询插值接口

v支持iplat组态回放

修复缺陷:

v许可证过期重启服务时hd3ConfigCenter和hdnetmgr崩溃

vHDPubserver第一次推送内容不正确

vHDPubserverCPU占用过高问题

v权限配置用户所属组超过10个时重启hdnetmgr报错，修改允许用户所属组上限为100


3.8.0

3.8.0

3.8.0版本主要增加归档文件的导入功能和归档文件手动备份功能，具体请参考下文。

1.新增功能特性

v实时数据库iHD归档文件导入功能；

v实时数据库iHD归档文件手动备份功能。

2.修复的缺陷

v修复hdRTD2ihd服务崩溃，乱序存储问题；

v修复大数据采集器主备切换时不断重启问题；

v修复hdOPCUA发布服务中文点编码问题；

v修改HDPubServer插值查询接口，增加时间过滤，避免插值起始时间早于原始纪录时间插值失败问题；

v修改ihd2ihd配置界面，增加登陆用户信息配置，避免修改默认用户密码后存数据失败问题；

v修复hdArcfilebackup加载配置问题。

3.升级安装说明

1)3.2.1之前版本，先升级到3.2.1，再升级到3.5.0，再根据下图进行覆盖安装至3.8.0；2.4.5备份并升级至3.2.0案例，详情请点击在线用户手册链接：典型案例 > 典型案例13-iHD2.4.5备份恢复升级；

2)3.2.1～3.3.0版本，先升级到3.5.0，再根据下图进行覆盖安装至3.8.0。如果需要修改原来部署的单机切换双机热备,详情请点击在线用户手册链接：开始使用 > 安装和卸载 > 从单机到双机热备冗余的升级）；

3)3.5.0之前版本，先升级到3.5.0版本，再根据下图进行覆盖安装至3.8.0；

4)3.6.0之后版本，根据下图进行覆盖安装至3.8.0；

5)3.6.1版本覆盖安装3.7.5的注意事项：

注意：3.6.1覆盖安装3.7.5升级后，log.xml文件末尾</logc>上面需要手工添加一段配置信息，如下：

<appender name="hdopcuaFile" type="rollingfile" logdir="C:/iHyperDB/Log/" prefix="hdopcua" rollingpolicy="sizerolling" layout="basic" />

<appender name="hdopcuaConsole" type="console" layout="basic" />

<category name="iHyperDB.hdopcua">

<output appender="hdopcuaFile" priority="debug" />

<output appender="hdopcuaConsole" priority="debug" />

</category>


3.8.0 P1

Navigation: 3.8.0 >

3.8.0 P1

 Return to chapter overview

3.8.0 P1补丁版本说明，具体请参考下文。

1.新增功能特性

vHDPubServer新增控制下发接口，新增编码配置；

vOPC采集器守护进程和OPC采集器状态监控界面优化；

viHD实时数据上云支持多分区发送。

2.修复的缺陷

v修改HDPubServer启动时连接网络服务失败后不重连问题；

v修改ihd2ihd按q键退出卡死问题；

v修复ihd关系库转储服务linux系统主备冗余问题；

v修复ihd备份恢复工具针对单个归档备份恢复失败问题；

v修复ihd手工备份缺陷和界面问题。


3.8.0 P2

Navigation: 3.8.0 >

3.8.0 P2

 Return to chapter overview

3.8.0 P2补丁版本说明，具体请参考下文。

1.新增功能特性

vHDPubServer支持数字量在线更新；

vHDPubServer新增根据条数历史查询，毫秒间隔插值接口；

vbb查询ihd点表信息增加查询条件，根据tag描述查询ihd点；

2.修复的缺陷

v修复hdBackupView恢复时路径设置不正确导致崩溃问题；

v修复hdOpcua服务非默认用户密码登录失败问题；


3.8.0 P3

Navigation: 3.8.0 >

3.8.0 P3

 Return to chapter overview

3.8.0 P3补丁版本说明，具体请参考下文。

1.新增功能特性

vHDPubServer新增tag点属性查询接口

viHD上云配置工具支持xlsx格式导入导出

v归档文件备份工具自动备份config文件

viHD上云服务支持DMM多点单值模式提高实时计算通道吞吐量

2.修复的缺陷

v修复内核归档大文件使用空间不正确问题

v修复iHD上云服务更新时间戳不正确导致配置中心主备同步失败问题

v修复iHD2iHDCollectorConfig导入点类型不正确问题


3.8.0 P4

Navigation: 3.8.0 >

3.8.0 P4

 Return to chapter overview

3.8.0 P4补丁版本说明，具体请参考下文。

1.新增功能特性

vHDPubServer启动初始化性能提升

vHPPubServer支持全量推送

2.修复的缺陷

v修复hdKingAPI注销接口未清理注册点缓存问题

v修复上云服务增加多点单值数据包后发送数据不正确问题

v修复优化批量插值接口后回放查询返回数据顺序错误

v修复hdOpcua加点失败问题

v修复配置同步Scan属性不正确问题


3.8.0 P5

Navigation: 3.8.0 >

3.8.0 P5

 Return to chapter overview

3.8.0 P5补丁版本说明，具体请参考下文。

1.新增功能特性

viHD采集器配置工具优化,增加备份及恢复功能

v增加采集器修改和删除操作记录履历，方便问题追溯

vOPC采集布尔类型数据为-1时增加转换配置，可转为0/1处理

v增加HDPubServer批量查询点是否存在接口

2.修复的缺陷

v修复按时间点查询string/blob历史记录内存泄露

v修复组态回放批量查询插值接口返回数据顺序不正确问题

v修复数字量类型计算点前值计算不正确问题

v修复大数据采集器单机没有转发问题（单机的配置EnableRyBigData="1"）

v修复hdOpcua退出进程时异常问题

v修复OPC采集器守护进程有时不启动采集器的问题

v修复HDPubServer链路追踪导致推送延迟


3.8.0 P6

Navigation: 3.8.0 >

3.8.0 P6

 Return to chapter overview

3.8.0 P6补丁版本说明，具体请参考下文。

1.新增功能特性

vHDPubServer服务端口可配置，支持BB多节点推送

vhdSysInfoSvc增加ihd运行时间统计记录

2.修复的缺陷

v修复OPCUA发布的点描述中文乱码问题

v修复PubServer全量推送周期比较长，注册点多时包大小超限

v修复计算点计算数字量类型数据时取值失败问题

v修复上云服务配置字符串类型时运行异常问题


3.8.0 P7

Navigation: 3.8.0 >

3.8.0 P7

 Return to chapter overview

3.8.0 P7补丁版本说明，具体请参考下文。

1.修复的缺陷

v修复 modbus采集器启动初始化类型有时不正确的问题

v修复iplat连接pubserver查询点名和描述中文乱码问题

v修复系统管理工具登陆失败仍然保持连接的问题

v修复P6 ConfigCenter.exe未更新问题


3.8.1

3.8.1

3.8.1版本主要优化了部分功能并做了缺陷修复，具体请参考下文：

1.功能优化

v支持Web方式配置上云服务；

v上云服务多点单值发送拆包优化，增加服务状态查询接口；

v增加内存快照存储异步接口；

v内核服务归档性能优化，增加序列缓存变更大小重置工具；

vhdRTD2ihd实时数据转发服务添加是否全量转发配置项，非全量转发根据tag点“保留参数3”属性判断是否转发；

vPython3SDK；

2.缺陷修复

v修复采集器守护进程方式默认隐藏采集器黑窗口，避免误关闭；

v修复采集器配置工具恢复配置时扫描组刷新频率不正确；

v修复RTD实时数据转发服务只转发配置归档属性的点问题，优化转发性能，支持100万条记录每秒；

v修复删除采集器sql错误提示；

v修改pubserver对接bb分组优化，判断没有注册时不加入组；


3.8.1 P1

Navigation: 3.8.1 >

3.8.1 P1

 Return to chapter overview

3.8.1 P1补丁版本说明，具体请参考下文。

1.新增功能特性

v采集器支持主备冗余;

v权限管理增强,在原有权限配置基础上新增资源组权限相关配置;

vJava SDK支持API选项配置，查询所有属性等接口;

vHDPubServer新增返回vtq批量同步读接口;

2.修复的缺陷

v修复HPPubServer加点接口因为描述过长导致的崩溃;

v修复实时数据上云dm模式下内存泄漏;

v修改ihd2ihd配置界面导入流程过滤不存在的点的导入;

v修复统计服务每日模式下起始时间有偏差时计算范围出现偏差问题;


3.8.1 P2

Navigation: 3.8.1 >

3.8.1 P2

 Return to chapter overview

3.8.1 P2补丁版本说明，具体请参考下文。

1.功能优化

v系统管理工具框架增加查询许可最大支持点数功能;

v系统管理工具实时记录和历史记录查询增加设置字符串数据编码功能;

vExcel/WPS插件tag上传增加指定数据节点功能;

2.修复的缺陷

v修复OPC采集器重连未重新注册问题;

v修复采集器冗余状态更新错误提示时间乱序问题;

v修复iHD2iHD采集器界面添加点位超过一千点缺少问题;

v修复ihd上云时DMM格式数值系数转换失效问题;

v修复PubServer查询原始值时点名解析失败问题；


3.9.0

3.9.0

3.9.0版本新增功能有ODBC驱动支持WPS、WebAPI、Excel新增自定义函数等等，并做了缺陷修复，具体请参考下文：

1.新增功能

vODBC驱动数据支持WPS加载查看；

vJDBC/ODBC接口查询支持实时记录；

vOPC采集器支持通知方式获取变化数据；

vweb客户端管理功能；

vExcel新增自定义函数；

v权限管理支持资源组，可配置tag查询权限；

2.缺陷修复

v修复hdRTD2ihd实时数据转发服务缓存大小不能设置；


3.9.1

3.9.1

3.9.1版本主要新增Excel加载项界面新增GUI，并做了缺陷修复，具体请参考下文：

1.功能新增

vExcel加载项界面新增图形用户界面；

2.缺陷修复

v修复安装程序最大缓存设置校验问题；

v修复反复设置CCCmd命令导致配置中心处理字符串过长响应慢问题；

v修复数据上云网络闪断失败出现大量的log问题；

v修复ihd2ihd配置工具未登录查询出错问题；

v修复采集器配置工具冗余配置保存失败问题；

v修复kernel重启后Pubserver推送停止问题；

v修复模拟量压缩率为0时未压缩的问题；


3.9.2

3.9.2

3.9.2版本主要新增Excel相关功能、客户端访问控制功能、PubServer相关功能、hdWeb相关功能，并做了缺陷修复，具体请参考下文：

1.功能新增

vExcel插件支持用户和用户组批量上传；

v客户端新增访问控制功能，通过将IP范围段与用户之间进行关联来实现；

vPubServer增加获取ihd量程信息，通过数据传输服务可将iHD中的数据量程等信息发送到iPlat-dm模块；

vWeb客户端增加数据节点配置、采集器状态查询等；

2.缺陷修复

v修复统计点，统计计算接口过滤表达式计算问题

v修复RPCServer查询属性信息部分字段中文显示乱码问题

v修复KingAPI接口反复增删tag点时，本地点名ID缓存更新不及时，导致相关操作失败问题

v修复PubServer更新数字量状态集不正确问题


3.9.3

3.9.3

3.9.3 版本主要新增客户端系统管理工具修改Tag点名、采集器可以根据操作系统用户显示当前用户勾选状态、PubServer对接BA组态趋势支持负量程上下限，并做了缺陷修复，具体请参考下文：

1.功能新增

v系统管理工具增加支持Tag点名修改；

v采集器配置工具本地采集器根据操作系统用户显示当前用户勾选状态；

vPubServer对接BA组态趋势支持负量程上下限，由于BA量程转换支持负比例，满量程可以配置负数，并且组态趋势需要支持按照量程来获取上下限趋势，为了方便组态趋势处理，故AI、AO、DI、DO这几类点支持最小值和量程范围两个域；

2.缺陷修复

v修复PubServer启动时推送配置初始化不正确导致数据不推送问题

v修复PubServer更新数字量缓存错误的问题

v修复OPC采集器在线加点失败有时异常退出问题

v修复OPC采集器从opcserver获取类型失败后获取数据不正确问题

v修复备份配置导致客户端查询超时问题

v修复OPCServer发布查询全量点导致客户端查询超时问题

v修复主备采集器部署模式后启动的会抢夺活动状态问题

v修复计算服务加点时失败后续没有重新初始化问题

v修复批量上传tag点关联资源组默认删除原有资源组问题

v修复节点权限同步太慢的问题

v修复资源组关联Tag点列表翻页查询问题


3.9.4

3.9.4

· 运行要求

硬件要求：

·处理器：>=Intel Xeon(TM) 8 CPU * 3.00GHz

·内存配置：>=16G

·硬盘配置：>=500G

·网卡：>=1G

操作系统要求：

·服务端：Windows Server 2008 64位 R2 以上（企业版），Centos 7/麒麟V10 64位

·客户端：Windows7 64位以上版本

· 功能增改

新增功能：

1.配置中心多线程优化；

2.Pubserver查询配置和数据多线程优化；

3.Excel插件优化支持多点多时间点查询，支持拖动自动填充自定义函数参数；

4.新增配置中心configcenter连接监控信息；

5.新增客户端界面可查看所有连接ihd配置中心的ip；

6.opc采集器是否写停机记录提供配置项；

缺陷修复：

1.ConfigCenter访问控制无法停用SDK客户端；

2.修改点名，计算点和统计点对应的源点名称没有修改；

3.统计计算点关联资源组异常；

4.同步用户组权限不一致；

5.Tag 点下载， 高级查询结果下载没有进度条；

6.RPCServer查询数据时错误码返回不正确；

7.平台运营BIOP30中显示的永久许可信息错误；

8.冗余同步一直失败；

9.使用Excel 修改digital点， 不包含数字量状态集列，会将点的数字量状态集改为Default；

10. opcserver获取大量配置导致服务端其他请求超时不能登录；

11. windows系统hdArchiveBackup进程停止不了；

12. HD OpcServer查询点不存在时仍不断发送查询id0的tag配置；

13. 全新安装配置中心和默认数据节点ip均未设置信任；

14. 新添加的tag配置查询时缺少部分属性，创建者、修改者、创建日期、修改日期不正确

15. opc采集器运行后，第一个新添加的点不采集；

16. pubserver查询配置版本失败出现异常；

17. 配置中心cleartagnamehistory消息未处理场景；

18. configcenter主备同步tagresourcegroup不一致问题；

· 升级说明：

Windows：运行exe安装程序

Linux：运行hdupdate脚本


3.9.5

3.9.5

· 运行要求

硬件要求：

·处理器：>=Intel Xeon(TM) 8 CPU * 3.00GHz

·内存配置：>=16G

·硬盘配置：>=500G

·网卡：>=1G

操作系统要求：

·服务端：Windows Server 2008 64位 R2 以上（企业版），Centos 7/麒麟V10 64位

·客户端：Windows7 64位以上版本

· 功能增改

新增功能：

1.查询历史记录支持配置多线程

2.采集关系数据库数据源支持视图、Tag点名映射

3.Excel/WPS插件支持二合一安装

4.采集器启动功能优化，本地采集器配置支持按名称查询

缺陷修复：

1. 修复日志级别由低改为高后, LOGC_宏 >= *(int*)(cat) 判断失效导致的记录日志性能问题

2. ConfigCenter主备同步优化，避免主备不一致

3. Configcenter性能优化，避免配置修改比较慢导致查询操作锁住

4. 批量修改点名未校验重复点名

5. 内外网部署配置情况下数据节点无法同步信任配置

6. Excel 插件，查询点弹框界面弹出时，可以切换到其他界面，但鼠标焦点还在查询点框

7. 采集器或设备删除后相关系统点与资源组关联没有删除

8. Excel统计计算函数输出数值可修改小数位

9. Excel插件在使用下拉菜单中的查询实时值时选择不存在的点Excel出现闪退

10. Excel按行查，数据太多时出现异常

11. Excel查询条件设置开始时间晚于结束时间，点击查询后会出现异常报错

12. Linux RPCServer查询进程状态有时崩溃

13. Rpcserver查询一个tag的多个时间点插值，查询不到的时刻没有子错误码

14. 系统管理工具记录查询界面导入点表时TagID为空出现异常

15. Opc采集器配置界面，启动采集器界面错乱

16. 系统管理工具浏览Opc地址报错

17. Opc采集器冗余时， 主备机同时运行后，停止其中的一个采集器会添加一条停记录

18. 采集器变更历史未清理导致查询慢

19. Opc冗余采集器配置的IP/端口号重复、配置文件格式错乱问题

20. 关系库采集oracle字段名小写失败问题

· 升级说明：

Windows：运行exe安装程序，opc采集器如果有主备需一起升级

Linux：运行hdupdate脚本


3.9.6

3.9.6

3.9.6版本相对于3.9.5版本主要增加对多个OPCUA发布服务程序支持，OPC采集优化，插件功能性能优化等功能，具体请参考下文。

·运行要求：

硬件要求：

处理器：>=Intel Xeon(TM) 8 CPU * 3.00GHz

内存配置：>=16G

硬盘配置：>=500G

网卡：>=1G

·操作系统要求：

服务端：Windows Server 2008 64位 R2 以上（企业版），Centos 7、麒麟V10 64位（服务器版）

客户端：Windows7 64位以上版本

1.新增功能特性

vIHD的OPCUA发布服务由原来的1个提升至可支持32个发布服务器程序，并支持选点界面和用户鉴权功能；

vOPCUA发布功能现已支持统计点和计算点；

vOPC采集器现已提供字符串转数字量功能；

v用户现在可以对采集器进行排序和日志路径配置；

vExcel和WPS插件现已支持时间统计函数；

vIHD新增默认可读用户组，该组用户可查询所有点的配置，该组不可删除；

2.修复的缺陷

v修复了IHD改为云上配置后无法添加点的缺陷；

v修复了Linux上云配置不正确启动异常以及配置修改时重启进程无法停止的缺陷；

v修复了Excel插件不支持sheet名包含“#”特殊字符的缺陷；

v修复了Excel插件查询结果排列方式不能保存的缺陷；

v修复了客户端查询资源组关联Tag点超时后无错误提示的缺陷。

v修复了Excel插件在使用tag下载功能，无筛选条件时表格内的采集属性为空的缺陷；

v修复了OPC采集器设备的活动点总点数统计不准确的缺陷；

v修复了关系库采集器不能采集字符串的缺陷；

v修复了WPS插件中错误查询功能找不到错误码的缺陷；

v修复了Excel插件统计标准差计算不出的缺陷；

3.升级安装说明

1)Windows：运行exe安装程序；

2)Linux：运行hdupdate脚本；


3.0

3.0